Quirky Color/Materials Window Behavior

sketchup
bug
mac

#1

Hello!

I have been experiencing an issue in SketchUp 2018 Pro wherein the Color window no longer allows me to resize the color/material well (as I can do in SU2017), specifically in relation to the lower portion of the window that comprises the editing space and “color picker” of the Color window.

Hopefully the following image will illustrate how the lower editing section of the window occupies half of the onscreen space of the Color window (of which I cannot resize). In comparison, the following image should also illustrate that I can only change the size of the upper section of the window. In the 2017 version of SketchUp Pro I am able to resize the window so that the large majority of the window is dedicated to in-moddel colors and materials.

The window behaves as though there is a weird, unadjustable, expanding spacer at the end of the layout for that bottom portion of the window.
After searching on the forum, it doesn’t seem that anyone else experiencing a similar issue, so I am wondering if this is an isolated issue for me. I don’t know if this is a SketchUp 2018 issue, a macOS issue, or a combination of the two.
I have tried finding and manipulating the traditional “divider-resizer”, but it doesn’t seem to exist.
I have tried resetting Workspace preference, but this has had no effect.
I really hate to go the old school route of uninstalling and reinstalling SU2018 as I don’t care to trudge through reinstalling and setting up my plugins and the like. I’d rather just carry on, however I’d still like to know what’s at least causing this.

At any rate, I wanted to reach out to the pros who might have a stronger insight to what might be causing this weird issue.
If I can help in any other way, please let me know and Ill see to what I can.

Thank you for you time!
Cheers!


#2

When I downloaded another copy of SketchUp Make 2017 recently, it automatically copied all my extensions to the new version. I didn’t have to reinstall any extensions.


#3

Did you install SketchUp 2017 on the same computer that had it before? SketchUp does not automatically install extensions in a new version but if you had 2017 installed and reinstalled it, it would find your extensions in the User Plugins folder. If you had deleted that folder before installing SU2017 again, those extensions wouldn’t appear.

SketchUp does not automatically install extensions from an older version, either. Each version is it’s own install and has its own Plugins folder.


#4

This is a question for @Barry the former Apple employee.


#5

Yes & I didn’t uninstall the other one. I now have 2 SketchUp Makes.


#6

Is there a way to reset / delete & rebuild any preferences for the Materials pallet?

I’m now having aberrant material selection behaviors. For example, I created a new material for an object but as I apply the new material to the object, another material is automatically substitute in place of the new material that was created and verified to be selected for use.
The only thing that I can think of at this point is to repair/reset a preference somewhere but I cannot seem to figure out which one specifically.

I may be looking at wiping all of SketchUp from my drive and performing a complete reinstall.

To the point originally posted, I’m now seeing tons of swatch boxes after a recent system upgrade…