Push/pull tool sometimes moves sheet


#1

I have a drawing made of a series of joined arcs, looking something like a winding race track. When using the push/pull tool to extrude the sheet solid into a 3D solid of certain height, it moves the sheet to that height. What is created is when the view is flipped 180 deg is a sheet channel rather than the expected 3D solid. When i tried extruding the opposite direction, some of my arcs disappeared. This does not always happen every time, however. Any thoughts?


#2

Post screenshots or better yet the model file.


#3

Where do i find the links for uploading files?


#4

#5

Thanks, Dan. Here is the file.cob-tp-plt.skp (302.3 KB)


#6

Tap ctrl with the PushPull tool and a little cross will appear, this will leave a face at the starting point.


#7

No problem, drag and drop also works on Windows.


#8

Thanks, that worked.


#9

Tapping control ( or alt on mac) will create a solid but will not solve the problem with the reversed faces.


to create a ‘Manifold’ Solid you must first get rid of the centerline, then select the face and copy it, Get rid of the original (Erase) then paste -in place the copied Face ,Select,right-click_> reverse faces.
You will then create a manifold, true solid.
It is important to be alert , regarding which side of the face you’re ‘Pulling’ , I always have the Entity Info nearby. It is like putting on a shirt in the morning inside-out , not noticing till someone is telling you.
I presume that, after you created the curves , you’d painted the faces but SketchUp always faces ‘down’ when making a face with arc’s and lines. It is as if you are already looking inside the box, before pulling the face up to a solid. In doing so, you’ve painted the 'soon to be ’ inside off the solid.
Best workaround is to first make the geometry and later on paint the faces.