Punching hole into irregular shape

Hello.

I have been struggling with what I guess is a simple task for hours if anyone can help me out?

I need to create a hole in shape which is not square and when I do so everything falls apart.

My method is to create a cylinder
struggle.skp (1.3 MB)
put that where I want it, explode it then intersect it with the model in the hopes it will leave behind a punched out hole, but instead all hell break loose with random deleted and filled in bits everywhere. I have run out of energy

If anyone can give me a clue how to do this I would really appreciate it!

What version of SketchUp are you actually using? Your profile says SketchUp Free (Web) but the file is saved as a version 2017 file.

One way to do this would be to get rid of the cylinder, draw a circle on the flat face and use Push/Pull to push it fully into the central hole. Then select the geometry, use Intersect Faces and then erase the unneeded stuff.

If you are using SketchUp 2017 Make you could make a solid component of the knob and then use the Subtract tool in Bool Tools 2 to create the hole from the cylinder.

Either way, you’d make your job a heckuva lot easier if you’d rotate the knob so the slot and the face that needs the hole is on axis. As it is your cylinder is not aligned correctly. Here I’ve rotated the knob.

It would also help if you drag out circle radii on axis.

Thanks Dave I am on 2017.

I did exactly as you suggested made a circle on the flat and pushed through. But did not get the result you have. When I deleted unneeded stuff it took out various rectangles of the main know as well, I tried drawing them back in but some simply would not

I will look up bool tools and thanks for the tips. I have ticked along with sketchup for years and this is still my level of understanding lol.

Sounds like you didn’t use the Intersect Faces step.

Is there supposed to be a hole in the outside of the knob to allow access to a screw?

Assuming there is, here’s the hole created with Difference in Bool Tools 2.
sub

thats totally correct, I tried doing it in one but everything melted down even worse!

I think I am hitting intersect with model rather than faces?

You make it look very easy, I will take another stab tomorrow!

You might try scaling the model up. When I model for 3D printing I set model units to meters. I would model your knob at 35 meters in diameter. That will help you avoid the tiny face problem. When you have completed the model and are ready to export the .stl, you have a couple of options depending on the printer software. If it allows you to enter the import units, you can export the.stl without scaling the model down first. If it doesn’t allow that, scale the model down before export.

Again very sensible advice. I am excited to give it another go tomorrow. Believe it or not this simple model is the most complicated have managed lol. I expect the latest sketchup is far better, but a bit out my price range.

Humm, there does not seem to be a lot of choices for intersecting. i.e. the only choice is to intersect with model?

The booltool looks good but I don’t have 30 quid to spend on a knob model right now!

Though to be fair making the model bigger seems to have sorted it

That would imply to me that you haven’t got the right selection before right clicking.

Understood. Presumably this knob isn’t the only thing you’ll model in SketchUp. The Bool Tools 2 set is extremely useful for a load of different things.

Illustrating what I described about exporting. In this case I left the knob at 37 meters across but uploaded the .stl in millimeters.

Not all slicers allow the user to select the import units and you’d need to check the one you are using. i.Materialise, which I show here, does allow the user to choose. I forget which slicer our Robotics team uses but it also allows that. It’s a nice option especially when you need to model small details.