PSD file as texture

I have always just used jpgs and png for textures in SketchUp and I recently found out that SketchUp supports PSD file as well. After some tests and studying, I found out that it is just converting to a rater (jpg) and losing original PSD’s layers and effects.

This is not a problem as I understand that bringing and maintaining PSD file as texture can be very tricky business. This is why I thought SketchUp doesn’t support PSD the first place.

However, I am slightly confused as some PSD will be applied correctly and some will not show included image at all. Resulting just white on SketchUp material editor.

I attach two PSD files - Test 01.psd and Test 02.psd

Test 01 works as expected whilst Test 02 doesn’t.

Test 02.psd (59.8 KB)
Test 01.psd (110.9 KB)

Can anyone tell me if this is a bug, or if expected behavior; tell me what are the necessary requirement for PSD file to work in SketchUp?

there seems to be issues with layers and transparency when viewed in other apps…

I don’t have PS, but if I split your two files I can see each has 3 layers…

If I view the originals on any app, they look like psd1-0 and psd2-1…


It isn’t a SketchUp issue, but something to do with how Photoshop files can use compressed data. Read the solution here:

You will notice that doing a preview in Finder also doesn’t show the image. Your file can be quickly fixed by doing a Save As, I didn’t even need to turn off that preferences option to get a file that works in SketchUp.

John, you can delete the white layer, draw new things, Save, and still the test 2 file will fail. But a Save As of the original fixes things.

Colin, I just ran them through ‘convert’ to see how they were made up…

convert ~/Downloads/Test\ 01.psd -set dispose Background -coalesce /tmp/psd1.png

Joseph, personally I would avoid using any ‘propriety’ format inside documents I need to share, even if they did work locally on my machine…



saving with the previews checked and maximizing compatibility did the trick!
I am not sure which of those two really does the trick though. I suppose the preview.
Thanks @colin .
I knew it wasn’t SketchUp issue, just didn’t really know the difference in two.

Are you saying avoid using PSD file?
for that, yeah I normally do. I was just testing out since i didn’t notice it takes PSD files, but confused when it didn’t for some files.

I will continue to use jpgs and pngs anyways

Pretty sure it’s not a PSD once you have imported it, any more than say a DXF would still be DXF. It will just be a texture.

AFAIK, SketchUp also resamples all imported raster images that exceed 1024 (or 2048 with Use Maximum Texture Size). For best quality it would perhaps be best to do that yourself before importing.


I strongly suspect that telling PhotoShop to save previews is the key. Photoshop layers act on the ones below them according to their per-layer properties. I doubt SketchUp’s importer knows how to replicate these layering operations to produce a raster, so without the pre-generated preview it doesn’t know anything except the gross size of the image.

1 Like

if you export to dae, you get a psd file for an image and a png for a texture…

so, it converts for textures but stores images in original format…


I didn’t know “Maximum Texture Size” still caps as 2048px. Kinda weird the word maximum just means twice the normal amount.

Because when I am bringing large plans as raster I have brought them in as 5000px before, and it would mean the excess is wasted.

Does this 2048px cap apply when it is displaying the image? Or the raster that’s embedded into the file will be trimmed as well?

Just did little bit of research. The “Use maximum texture size” option will display the image at a new maximum resolution of up to 4096 x 4096 pixels. - according to @ChrisDizon

Also, I have tried “Edit texture image in external editor” of the image that was larger than 4096px, and it maintained its original size. Therefore it means, if all of the gathered data is true, SketchUp will store original size and resolution of the image assigned, but display down-sampled version of image at 1024px or 4096px depending on your settings.

Well, this means that I have no point in adding an image larger than 4096px if I don’t want really fat file size.

Can anyone confirm this for me? (I have no way of checking display resolution of image in SketchUp)

1 Like

Chris should know what he is talking about. I mis-remembered the maximum size.

Independently of texture size, a Photomatch scene can display and export an image in full resolution. This is a great feature as for instance aerial photos would become intolerably blurry if downsampled.