Problems with Sketchup Volume Calculation Accuracy

I was using sketchup to visualize some common calculus problems and came to the conclusion that sketchup is not measuring volume correctly for some solids. In the image below you can see the formula for calculating the volume of a solid and that solid reproduced in Sketchup. I checked the dimensions of the solid they are correct. What could be causing this?

I just realized the problem as soon as I posted the thread. Sketchup does not calculate round solids as perfect circles even if they are smooth shaded.

True.

I got this with more segments in the circle for the path.

BTW, please complete your profile with SketchUp version and license type.

1 Like

SketchUp represents the skin of an object using a mesh of connected polygons. The shape you show can only be approximated by that kind of surface. SketchUp will always underestimate the ideal volume. Unless you need an exact answer, as @DaveR pointed out, you can improve the estimate by increasing the number of polygons used in SketchUp’s representation. Typically this involves choosing a higher number of sides before drawing any curved shape.

PS, it will also underestimate the “area” of shapes with convex curves! be aware

1 Like

It’s curious that it comes out to 2144.55 whether you use 360 segments or 999 segments.

puts Math::PI

gives a reasonable value for π, so I’m not sure why SketchUp comes out as 0.11 cubic meters different.

If you scale things up, first, it does get’s better:


somewhere between 360 and 999, the incapacity of SketchUp drawing tiny faces would be leading (the length of each segment will be the same), if scaled up a factor of 1000, the number will limit the precision.

I scaled up by a factor of 1000, rotated a circle half a segment, drew the shorter edge and used that to create the two triangled faces that were than quadrotated:

Precision.skp (573,2 KB)

π is closer to this custom fraction I have - 5969/1900.
Don’t use 22/7, it is bad.
3.1415926535

To get the amount of error there is SketchUp would need to be using 3.1414, and I think that it is using 3.141592653589793

To check if SKP 2017 calculates my wall volumes (m3) correctly, I first made a surface 1000 x 1000 mm. SKP reports that surface area correctly at 1,000,000 m2. I then drag this 1 sq m surface up 1000 mm to create a 1 cube meter object and make it a component. SKP reports the volume as 1,000,000,018 mm. Why does SKP add an error of 0.0000000018 mm to every cubic meter?

I’m not seeing that here.

Do you have Length Snapping enabled? How far is your cube from the origin?

Share the .skp file.

1 Like

Thanks for prompt reply DaveR. When I open a new skp file the cube reports correctly 1,000,000,000 mm3. On Length Snapping - yes this is checked. When I create a new cube on the origin axis, in my working model, I still get the 0.000000018 mm error.

But my model house and plot was screwed away from the default skp alignment so my model aligned with the google geo-location map image. Could that sewing upset the volume?

I will send model file.

You should turn this off. It can create small dimensional errors.

It might. How did you get a Google geo-location map into Sketchup?

Again, share the .skp file so we can see what you have exactly.

Which version of SketchUp 2017 are you running? Please complete your profile.

It is possible that length-snapping and rounding are causing the issue… you have your dimension showing nothing after a full number… if you set input to show numbers after the decimal point (I.e. 1000.0000) you may see that your cube is not perfect

1 Like

I couldn’t replicate it even with a randomly placed axis. I would blame Length Snapping.

Just improved precision to 0.000 and I see an improvement on the 1 m cube - almost a perfect cube. But only get a perfect volume on a fresh new model page.

Older cube A

New Cube B

I’ll try 4 decimal places and see if cube C is perfect.

I’m a one model man. So still on SKP 2017 Make. Win 11, 64 bit.

I note I can only add 3 decimals in 2017 Make. What about snap to angle - is my setup right?

I would recommend sharing your model for us to look at.

As I wrote before, turn off Length Snapping.

Share your house model with us so we can see exactly what you’ve got.

Please complete your profile.