Problem with Spacemouse and Logitech trackball trackball in Version 21.1.332 64 bit

Just loaded this version - SpaceMouse (latest software version) will only zoom in and out, no other motion, logitech trackball, same issue.

How can I revert to previous version in order to keep working?

John N…

Did you reinstall the drivers?

Did you make sure the firewall was off when you did (for the SM anyway?).

Did you install SketchUp first and then the 3DC driver? I’ve gotten what you are describing when the 3DC extension for SketchUp isn’t correctly installed. When that happens, all SketchUp sees are scroll events, which it takes as zoom.

In the last couple days I’ve had the same issue with Logitech Track Ball M570. After a restart of PC, I have to go to Logitech SetPoint settings and switch Middle Button to “Middle Button” from “Auto Scroll”
Tried to update drivers through Logitech but says no devices found. Which is weird since the Logitech SetPoint app recognizes it.

I’ve got several Logitech mice that have all be behaving in a squirrely manner lately. Not just with SketchUp but with every application. Updated the Setpoint app, cold reboots, no change. I wonder if a recent Windows update had anything to do with it.

1 Like

I wonder what hardware the current Logitech application (Logitech Options) supports? I too remember struggling with the Setpoint application, but the current Options has worked without a hitch with my MX mice. If the trackball doesn’t have extra buttons or functions, it might work adequately with the standard Windows mouse drivers.

I installed Setpoint and it told me it doesn’t support the M510 mouse and to install Options. I did that and it told me that it doesn’t support the M510 and to use Setpoint.

I think so, hopefully Logitech will come up with a fix.

Well, I’ve futzed with this all day. I guess that the Logitech trackball WAS working all along - I’d just forgotten how to use it since I had the SpaceMouse. That, however, isn’t working in Sketchup and I cannot find a way of coaxing it to do so.

SpaceMoluse is working in Autodesk Fusion 360, so it’s a Sketchup thing by the look of it. I guess I’ll go to Tech Support.

Thank you all for the helpful and focussing suggestions.

SketchUp doesn’t do anything to control input devices. Make sure you have the current drivers from 3D Connexion installed correctly.

I had an issue with the latest driver, just download the previous and install over the top. BTW : I keep all software and drivers on another drive.

Well, sir, you pointed me in the right direction on this one. I’m not exactly sure what I did to fix it, but a careful process of deleting and reloading a minimum set of the 3D utilities along with a full refresh of the Nvidia drivers gave me a solid working install that survives reboots, etc.
I had never studied the 3D driver set and its installation process, nor seen the entry in the Extensions on Sketchup, before. I know what to look for in future.
Thanks again!