Problem with line's arrow


I have a regular problem with my quotation lines.

The position of the arrows is random.

Inside, then outside, then inside…

I would like it to always be inside.
Do you have a solution?

Is there a reason why you use arrows? It depends on the size of the measurements, in some places the size of the text is too big for the measurement and the arrows change their position automatically, that’s why I don’t use them for measurements, I prefer dots or inclined lines, you can do that if it’s not a big deal.

I have a preference for arrow. But it’s not a probleme of place.
Because on the same line, the direction of the arrows changes!

The arrow changes as the smaller the dimension gets, the less room there is for the text (or so Layout thinks).
A way around this is to place the dimension where you want it, double click on the text to edit the dimension (not edit the text itself), then move the box away slightly so the arrows go back “inside” the dimension.

Some things to try

In the “Dimension Style” Panel:
Change your Extension Lines change the size to a smaller size
Change Leader Style to Curved

In the “Text Style” Panel
Change the Text Size to a smaller size. You can enter a size smaller than the drop down box lists; just type in a smaller number. I use 6 point.
Change the text color to a color that stands out. I use Red for dimension text and Green for labels and annotation notes.

In the "“Shape Style” panel
Change Stroke Color to match text color. Helps for readability or clarity.
Change stroke size to a finer line (smaller number).
Change Start Arrow and End Arrow to a compact shape of arrow from dropdown lists. also change size of arrow to a smaller size.

Link to Layout Help Documents

Delve deeper on sections via selection boxes and headings on bottom of page in link.

Another link pertaining to dimension styles.
Marking Dimensions | SketchUp Help.

A lot of info in these Layout Help files. Most likely many answers to questions that haven’t arisen yet.

Okay, but i have a line with circle when i move the texte.

You can edit the dimension to remove the dot and make the leader transparent if you don’t want to see it.

Here I removed the dot and made the leader a transparent red so it would still show.

Perhaps all you need to do is reduce the size of the text a little. What font are you using? Some fonts have more padding than others.

Or choose a one-segment leader and let the dimension text go to the end.

Okay, i have a lot solution.
Thank you very much !

What is the solution that works for you?

OK refer to my previous post.

  1. Turn off the leader (line with a circle)
    Note: the leader only appears when there is not room for the text between arrowheads
  2. Select a more compact arrowhead style
  3. Select a smaller text size
  4. Change (smaller) the size of the arrowhead.

Items 2-4 will allow a larger number to fit between the arrowheads.