Problem with Files' Icon Appearance

picture-1

Hello everyone,
I purchased SU 2018 Pro last year and upgraded to 2019. Everything was fine until I thought there is no need to have both versions in my computer . I uninstalled 2018 and problem starts by files appearing as a blank documents . I contacted sketch up Help , but nothing suggested could fix this problem. I reinstalled the version 2018 and problem solved!

Again after few months my computer started to work slowly and I thought to uninstall the 2018 version one more time. The problem appeared to be the same. I have attached a picture of how the files look like in here. I am wondering if someone could tell me what is wrong and how to fix it. Thank you.

Try repairing v2019 as follows…

  • Whilst logged into Windows as your normal user-account [NOT the special system administrator-account, BUT if your normal user has some admin-powers, then that’s OK], ensure SketchUp is closed.
  • Find the v2018 OR v2019 installer’s exe file - usually in your Downloads folder.
  • Select the installer’s exe file’s icon and right-click > context-menu > “Run as administrator”.
  • When prompted choose “Repair”.
  • When it completes restart your PC and see if it helped…

Also choose a SKP file’s icon and right-click > context-menu > Open with…
Choose SketchUp v2019 [or v2018] and tick the ‘always open with…’ option.
That might also help your SKP icon display…

Thank you for your time. I ran the troubleshooter for this program .It sounds that SU 2019 is an incompatible program . Generally, I did not have an efficent working experience since I downloaded SU 2019.

??? Sketchup can have multiple versions on the same PC at the same time they are “stand alone” apps. Also you can have the 2018 and 2019 versions open at the same time Layout can only have 1 instance open either 2018 or2019.

Unless you have installed it on a 32bit system, then 64bit-only v2019 should be “compatible” [whatever you mean by that?] - although having a low-grade Graphics-Card can cause issues, this is NOT what you have reported.

Have you followed my guidance on a “Repair” AND resetting the ‘open-with’ option ??
If not, then why not ?

1

I understand that both versions can be opened at the same time , but this will not help me. I want only the earliest version installed in my computer. I have attached another picture of how the files look like. One of them is skb. file another one is skp.

The lack of an image in the SKP icon suggests an incorrect installation !
I explained how to do a “Repair” - it’s the same for v2018 OR v2019 - whichever you want - both must be installed properly.
Also forcing Windows to open a SKP using a certain version of SketchUp can do no harm…

Yes, I followed your instructions , but I could not find the repair as an option.

Note that you need to be right clicking the SketchUp installer file not the SketchUp desktop shortcut which sometimes confuses some users.

When you select run as administrator on the installer you’ll probably get a windows permission option. Ok that and then the screen with “repair” option should appear.

Did you find the relevant SketchUp installer’s exe file - probably in your “Downloads” folder ?
I did NOT say the “SketchUp.exe” file in the “Program Files” subfolder !
I specifically said your “Downloads” folder !

If you open the right-click > context-menu of the installer’s exe there is always a “Run as administrator” option.
When that runs one of the options is “Repair”.

Obviously if your installation is done using another “locale” the language might vary - but the meaning of the words remains the same…

I tried the second solution as well. It shows only the SketchUp 2018 whcih is already uninstalled!! Thanks again.

So are you saying that v2019 is NOT installed ?
If so when you run the installer exe as explained before (“Run as administrator”), then there will be no “Repair” option - in that case choose “Install”…

You are not giving us the full picture here.
You should still “Repair” v2018, and NOT install v2019 - but the options are up to you…

It would be strange to say , but I can open the file in SU 2019, but when I right click on a file it doesn’t show the 2019 version only 2018 which I have already uninstalled! I have never confronted with such this bizarre problem!

It looks opening and saving files as Adminstrator in SU changes the Icons appearance. I will try with all other SU files and inform you as soon as I find it as a final solution. I really appreciate your time and efforts to describe your mind.

Don’t Open SKP files using “Run as administrator” - will cause unexpected issues, like drag-and-drop failing to work.

If SketchUp was installed using “Run as administrator” then the saved SKP files should respond properly?

I suspect this is all due to an incorrect installation of your versions of SketchUp.
Repairing them should help you resolve things ??

I uninstalled and installed the 2019 V for the third times. Now, it is working like a charm. Thank you!

How about updating your profile while you’re at it?