Problem with Ellipse 48 segments

bug

#1

When I trace an ellipse with 48 segments whith Sketchup 2017, it is not possible to use the tool gap with this ellipse while with 24 segments, it is OK
It works well also with Sketchup 2014


#2

Exactly how are you drawing the ellipse? What are its dimensions?


#3

Is this a “snap to axis” issue? The angle between the “nearest to axis” segment for a 48 segmented ellipse is less than for a 24 segmented ellipse.

If so, temporarily rotate the drawing axes.

edit: if it is a matter of size, scale up the ellipse 10x or even 100x before tracing it.


#4

The ellipse is 68mmx50mm. I used circle tool then the scale tool and then the gap tool for 1mm gap.
I scaled the sketch 100x before tracing the ellipse and it works well so it was the solution? Thanks a lot.


#5

The “gap tool”? What is the “gap tool”?

Here’s an ellipse with 48 sides of the dimensions you specified. No need to scale the model up or down or do anything else special.


#6

When using Gap tool, the result is a cicle instead of a ellipse!


#7

Sorry, this is Gap tool, I don’t know the name in english.


#8

Oh, in English the “offset” tool. I can reproduce what you show. It seems to me to be a bug.


#9

Offset tool.

What do you really want in the end?

Is the group being scaled or is it the geometry within getting scaled?


#10

If you offset by only a small amount, you get an ellipse similar to the one you started with, but if you choose a larger offset as soon as you release the mouse the offset shape reverts to a circle. I tried to make an animation but it seems that SU 2017’s new graphics make Licecap unhappy - I got a black gif!


#11

Hmmm… I see it now, too. If the curve is exploded it works fine, too.


#12

_

___

I want to do with Sketchup 2017 what I can easilydo with Sketchup 2014! see the picture made with Sketchup 2014


#13

I did not have to scale the sketch with Sketchup 2014.


#14

Although I’ve just seen the ellipse revert to a circle ones, I can’t reproduce it (the bug) anymore. Neither with large offset (10mm or 20mm) nor with small offset (1mm). Not inward, not outward.

I’ve tried several times:

  • with raw geometry
  • with a scaled circle (raw geometry) inside a group
  • with a scaled group containing the circle.

All circles had 48 segments, > ellipse 68mm by 50mm

SketchUp 2017

I wonder what triggered the ellipse to revert to the circle just that one time.


#15

It’s strange. Maybe it depends on the amount by which the circle was scaled to create the ellipse?


#16

@slbaumgartner Thanks for posting that gif. We’re aware of the issue and investigating how to fix the problem.


#17

I am having this same problem SU 2017, Works when I draw a 300cm circle (50 sides) but not a 300mm circle.


#18

It’s not clear it depends on the size of the circle or the number of sides - but take heart: @mchandler, an official SketchUp Team Member, posted above that they are working on a fix!