Pro 2019 Layers Inspector Palette is missing!


I am brand new to SketchUp Pro and I can’t find my Layers Inspector Palette.

The Layers Dropdown is present with Layer 0, but how do I add and manage new layers!!!


– Joe

You should find the Layers panel in the Default tray. If it’s not there, go to Window>Default Tray and tick it on.

It is selected there and the Layer dropdown is there but NOT the inspector!

Can you show a screen shot of what you are seeing?

It should look something like this but with only Layer 0 in a new file.

How do I post the screen shot?

So you aren’t seeing the default tray at all because you have it set to hide on the right. Hover on the tab on the right edge of the screen. If you want to keep the tray visible all the time, click the pin icon at the top of it when it is showing.

I would suggest that you not bother with the Layers toolbar which you have displayed at the top of your screen. It’ll just get you into trouble. Selecting different layers in that dropdown list makes them the active layer. Correct use of layers involves leaving Layer 0 active at all times, creating all geometry (edges and faces) on Layer 0 and leaving them there. Only components and groups get other layers assigned to them.


How do I add a component to a layer?

You add a layer attribute to a component in Entity Info. Select the component in the model, and choose the layer from the Layer drop down.


The Layers Drop Down shows only Layer 0

Hmmmm… When you installed SketchUp did you right click on the downloaded installer and select Run as administrator?

You don’t use that drop down to change the layer assignment for the component, anyway. Open Entity Info at the top of the Default Tray. It is there that you set the layer for component.

You probably don’t want to set a dash style for Layer 0 since all edges are to be made and remain on that layer. Set dashes if you want them for the layers which get associated with the components.


Should I reinstall it now?

Yes. Well, find the installer, right click on it and select Run as administrator. When give the option, select Repair.Make sure you quit out of SketchUp first.

will do now

Just an FYI for readers. You need only hover over the tab to have it slide out into view (save your click) and then keep the mouse cursor over the tray to use it. Moving the cursor outside the tray will collapse it again.


A million thanks!!!

Great. Again, though, you don’t need the Layers drop down toolbar. It won’t change the layer assignment for components and groups. Selecting a different layer in the drop down changes the active layer which you shouldn’t do. Layer 0 should always be the active layer in SketchUp.