Png Images not loading / importing into drawing

So today my sketchup wont Import any png or jpegs into the drawing file. It usually imports images fine but today every-time i try nothing happens. Also tried to import the images as textures as an alternative but anytime i go into “colours in model” and right click load texture I select the PNG or the Jpeg but it just doesn’t appear as a colour or texture. Its as though the programme is refusing to recognise any image files or load them into the programme. Tried starting a new project to see it would work in a different drawing but still the same problem. Can not make heads nor tails of it. Any advice greatly appreciated.

Sounds like you may be running the program as an admin which means it won’t allow images.

Do you select the colors in model via the little house icon or via the list?

How would I change that ?

the list via the paint bucket tool

Where are those files located?
Try to create an image (screenshot) and drag it into the model’s viewport.(or via File> Import)