About using png or jpg imports as textures

After upgrading to sketch up version 2023, I found that I can’t create new textures by importing images. May I know how to solve this?

What steps are you taking to import the image files?

Please correct your forum profile. SketchUp for Schools is web based.

When I want to create a new texture and tap on the local folder, I find that sketch up doesn’t recognise my png and jpg files.

OK. I’ll edit it now.

Where do you “tap on the local folder”?

First I would click on the create texture window, then click on that folder icon to select the texture I need. Isn’t that how it works?

That’s one way to create new materials. It works fine for me in SketchUp 2023.

I went through the same steps as you, but there is nothing in the folder, I have confirmed many times that there are jpg or png files in the folder.

Are they .jpg or .jpeg images? Do you already have a selected material to edit?

An alternative method is to draw a rectangle in the model space and then use File>Import. Choose Use image as Texture and apply it to the rectangle.

When you updated SketchUp did you right click on the installer and choose Run as administrator?

Well, I solved it, although not very conveniently. In the course of my enquiry I found other forum users with the same problem as me. His solution was to import the image by dragging and dropping it into the window that creates the material.

That’s another way, too.

Thank you for your answer.

You’re welcome. The import option should work for you like it does for me. You should figure out what’s wrong with the installation on your end.

For your interest, when creating a material using the new material button on Windows, the image can’t be .jpeg. Renaming the files to be .jpg works around the problem.

That has been fixed internally, and .jpeg should work ok in the next update we release.

That’s why I asked but the OP ignored the question.