Plugins not showing up in shortcut list

Hello I have 1 problem

When I assigned a repeated shortcut for a random function, it clearly showed that the Isolate Entities (vistools) did appear in the function list. But when I directly search for its name, it didn’t show up

I have also searched manually by scrolling through the list, but I couldn’t find its name (or its alternative name), the plugin is enabled, I set the mode to unrestricted, tried to reinstall and repair the application, emptied the folder where I had copied the extension, but nothing worked.
The only way i can use this plugin is to click on the icon, but I still want to assign the shortcut to speed up my workflow. The other extensions do appear in the shortcut list, but not Vistools extension

I don’t know that specific plugin, but it looks to Isolate Entities you need a selection.

So select an item that you want to (and able to) isolate, and keep it selected. Now, go and search for its name in Preferences, Shortcut list…