Please help! annoying 'pixelated' edges of surfaces

Hello

I’m wracking my brains to figure this out and coming up with nothing.

I’m getting the following issue, it gets worse the more I zoom in, triangles of the back colour of perpendicular surfaces, appear to bleed through on to other surfaces:

I am using a Lenovo Thinkpad P52 with an Nvidea Quadro P1000 graphics card, and 16gb memory.

I’ve tried the latest driver for Quadro P1000.
I’ve set the options within the nvidia control panel to use the quadro P1000 GPU for sketchup.
I’ve looked through other posts on here and can’t find any similar issues with the quadro P1000, nor can I find any other similar issues.

This is driving me nuts!

Thanks in advance for any help.

Dan

How far is your model from the SketchUp model origin? Does it have parts that are somewhere far away?
What is your Antialiasing setting set to (Window menu>Preferences>OpenGL)?

HI Anssi, thanks for the reply.

I’ve tried various anti-aliasing settings, from x0 to x64, the screen shot above was with x4, doesn’t seem to do anything noticeable.

I’ve zoomed out and added another screen capture to show where I am compared to the model (red circle is where i zoomed in):

You’ll see when the model is zoomed out, there is no problem, it only when i’m modeling on a small detail that it happens and it is very distracting.

Thanks for any further help

Dan

Can you attach the model.

house3-1.skp (4.8 MB)
here you go…

The problem seems to be the component “Laura*1”, I would guess it’s floating around in model space somewhere. If you select and delete it in the outliner the problem goes away…

Capture

EDIT: No not quite,there seems to be something else too which is affecting the model.

1 Like

Change Camera > Perspective

1 Like

Laura wasn’t that far away, only 74.9km!

There were also some “double bed” components more than a km away, inside “2s lower floor” component. I just deleted them, hope they weren’t too important.

house3-1_gm.skp (1.6 MB)

1 Like

Good find, I thought there might be something else out there but couldn’t find it before I got pulled away to a phone call from my tutor.

wow! How on earth did i manage that? Thank you @IanT, @McGordon, and everyone else. How do you go about checking for these distant objects? or how to avoid this in the future?

I use Ruby scripts to help find the largest objects, furthest translations, etc. Sometimes they can happen if you import objects someone else has made and they’re a long way from the origin. Maybe that extra copy of Laura came in with another model you imported?

1 Like

When you have some strange orbiting behaviour in a model or other camera oddities, the first thing you can do is Zoom Extents (CTRL+Z) or CAMERA menu>Zoom Extents. Your full model should fill the screen nicely. If your model appears small, then the camera has been affected by something out in the model-space somewhere, a stray entity.

Trouble is often finding them to remove. McGordon and others here have special scripts to find them, but as I’m not that clever I use process of elimination to try and find them. In your case “Laura 1” were simple, by looking in the Outliner Window I saw 2x Laura but only 1 appeared in the model space that I could see, very suspicious. By selecting Laura*1 in the Outliner, nothing highlighted blue in the model where it should be. So I delete that temporarily and try Zoom Extents again to see if it works. Better now but still some weird camera behaviour. The beds proved more difficult to find…

1 Like

One way is first to Zoom Extents. If your model appears very small, try a right to left selection window in turn above, to the left, to the right, and below what’s visible.

If Entity Info shows anything selected, erase it, and Zoom Extents again.

Go to the next area around the model, and repeat.

What this probably won’t find is any text that was attached to an object that has since been deleted, and flown off effectively to infinity.

1 Like