Planar in models


#1

I have used sketchup now for a couple of years and I have been impressed with it’s ease of use. But if you are working on highly detailed 3D models it has a real problem. If you use the solid model tools to extract one sold from another somehow the vertises get moved out of plane. What this means is if you want to attach something or draw a rectangle on the surface and extrude it, it will not do it because the new object is not on the same plane as the adjusted model. I am sure I have the wrong product but if anyone knows of a feature to align vertices to a plane please let me know. I bought Vertex tools but it does not align to plane it only averages the plane of the selected vertices. Try adding an extrudable shape to the main surface of this model. Test.skp (449.3 KB)


#2

I’d say your problems are being generated by working at Too Large a scale.
While it does help to scale small work up, if you go too big you also get errors.
The long edge of your top face is 198.62m SU tolerances over those distances will allow all sorts of slightly bent faces and create triangulation when some of those faces are edited.
Work at a more realistic scale and I’m sure your problems will go away.
As you see here, it now works.


#4

turning on ‘hidden line’ indicates that you have introduced a twist at some point…

it’s too obvious to be due to SU’s engine…

I mainly use a metres for millimetres template and never have odd twisting unless I accidentally create it…

scaling down and then back up will retain the ‘fix’ that @Box shows, but it won’t fix the other small errors on the end or underside…

john

@lynne, I have flagged your post, because it has nothing to do with this topic, delete it and start your own thread…


#5

Like the others, I found distortion that must have occurred during manipulation of the model. I found it easiest to redraw it making sure to keep edges on axis where appropriate. I didn’t wind up with the triangulation problem as you can see.


#6

Thank you both. Very helpful

The problems arise when I add or subtract another solid from the original. I will try to work on a more reasonable stage but I was advised to work much larger. As the product is mm not meters upsizing by 1000 was obvious choice. Disappointingly then that there is no Centimetre option. I will have to work in inches and convert when done. I still think that the product has too many obstacles for my type of work. I genuinely take 3 times longer fixing stuff than working. Because I am working and designing three components that have to work together I have to make constant changes. Drives me nuts. If you have a solid inspector try scaling the original up and down a couple of times, errors appear from nowhere. I will persevere a little longer but I just think it has too many bugs.


#7

Really?

It should take that long. Maybe your work flow could be modified to make it easier. I draw lots of small scale stuff in SketchUp and find it works very well even though it was intended for architectural scale models.


#8

How do you get model info?


#9

Look in the Window menu.


#10

I was looking at preferences???. How long did it take you to redraw my model? is it accurate? Is it a solid ? Can I try it?

Derek


#11

I don’t know. Twenty or thirty minutes or so. I rounded a few of the dimensions that were very close to be even but I don’t know if that made it accurate. It was solid when I got finished but I didn’t save it. I closed the program after making the image export.


#12

Worth a try

Thanks Dave.

Any idea why scaling should cause short edges or solid model issues. It seems every time I move it scale it drill another whole the model goes into crazy mode?


#13

I don’t know. I’ve net had that happen. On the other hand, I don’t scale up and down repeatedly when I’m working on smaller objects. I start the model at it’s normal size and create a component which I copy to one side. Then I scale that copy up by 100 or 1000 and I work on it until I’ve finished what I need to do. When I’ve finished, I close the large instance of the component and delete. Zoom Extents brings me back to the original. So drawing something like these knurled pins is a walk in the park.The knurled portion is 1/2 in. in dia.


#14

Christ mate that’s dammed good where do you get the surface finish from?


#15

The knurling texture was drawn in SketchUp. The metallic look and the shadows were created in a rendering application.


#16

I didn’t explain myself very well there.
I was pointing out that some of the twisting error triangulation could have been caused by working at such a large scale.
When things are that big you can put things together that show as planar because SU will bend large faces, but they can be a tiny bit misaligned so when you edit them with solid tools the large faces can end up breaking where the edges don’t quite line up, causing the triangular faces you are seeing.

So my suggestion was not to scale up so large in the first place.


#17

Also, turn off “Enable Length Snapping” in the Units dialog.


#18

That may explain why I get short edges fault in solid models. Thanks Jim


#19

That’s helpful. Any idea why I’m getting this highlighted vectors. Have I messed it up again?


#20

That looks like you have endpoints turned on in the style


#21

I know the frustration. I’ve seen planar elements get corrupted, and it’s hard to know just when and why it happened. I often us “Save As…” to leave versions of my model as I go, and can go back and retrieve parts from if need be (i.e. find a previous version before the corruption crept in). As john_drivenupthewall says, Show Hidden Geometry helps debug the mess. Here’s an example I had a little while ago.This aught to be a simple flat face with one door cut in, but hidden geometry is even connected to other faces not touching it. Copying just that face from a previous version wasn’t good enough. I had to explode and recreate a new group.


Accuracy paradox - a kind of Sketchup cancer