[PhlatBoyz Phlatscript] Gcode: (Warning move ...)

export
gcode
phlatboyz
phlatscript

#1

Hi, Newbe here. I’m making a simple 3D text on a test piece of wood .5 thick. When it generates the Gcode, I get this a number of times thru the code. I’m thinking that the plunge depth max is set at 0.0, but I can not find where you would change that. I have a 1/8" ball bit and the depth of the text is 5%.

Anyone get me going into the right direction?

G90 G21 G49 G17 F500
T1 M06
M3 S15000
G00 Z5.000
X26.253 Y23.937
(RAMP limiting Z to min_z @min_z)
G00 Z0.200
G01 X19.868 Y23.937 Z0.100 F500
X26.253 Y23.937 Z0.000
(Warning move Z=-0.600000mm LT min of 0.000000mm)
X19.868
G00 Z5.000
X26.253
(RAMP limiting Z to min_z @min_z)
G00 Z0.200
G01 X29.259 Y24.107 Z0.100 F500
X26.253 Y23.937 Z0.000
(Warning move Z=-0.600000mm LT min of 0.000000mm)
X29.259 Y24.107
(Warning move Z=-0.600000mm LT min of 0.000000mm)
X31.869 Y24.615
(Warning move Z=-0.600000mm LT min of 0.000000mm)


#2

Ok, after some reading and understanding, I found the options and set them as recommended, and it solved this issue. Strange, but it worked fine the last time I worked with it.

But it works now and thanks for having a great program.


#3

When what generates the Gcode ?

(SketchUp does not do this natively.)


#4

The Phlatboyz add on, created it.


#5

For their plugins, it is best to ask the question in their forums:


(Moved to Extensions category, and retitled thread.)