Performance differences using flat colour materials or jpegs

Hi I am visualising lots of tables with bottles and glasses on… I would like to import a picture of glasses and bottles into the surface of the bottle and glass shape (a flat made shape that always faces camera) but is it better to just fill the shape with flat colour to save cpu + memory etc for better performance?

There will be 200 of them its to show a large bar serving drinks!



A texture image will weigh more on file size and performance than a simple material color.
But if you keep the texture image size to a minimum you shouldn’t have any problems.

Here’s a quick example made with @TIG 's Image Trimmer plugin.

Beer.skp (1.4 MB)

Experiment with it. Try making an array of, say, 2500 of each component; 7500 total instances.
I found the model still performs quite well. You may want to turn off the shadows first.

More about Image Trimmer in this topic…


Great reply many thanks Geo!

…I have set my bottles and glasses on the tables with png textures…looks great, but I have also used a png image for the table surface. I then made my bottles and glasses semi tranparent so they look realistic but when I move above the table they cant be seen where the table surface cuts them from being seen completely for some reason?

I’m not able to picture the situation from your description.
Perhaps you would post a picture or better yet, a model file.

You might try setting Transparency quality to Medium or Nicer in Window menu>Styles>Edit>Face settings. PNG transparency often produces weird effects with the Faster setting (default).

As to the original question, if you have a decent graphics card that allows you to keep OpenGL Hardware acceleration on, using raster images and raster effects almost always beats creating geometry in performance. Large raster images have an impact on file size, but once loaded, they mostly run quite smoothly.


1 Like

See here the plate is behind the bottle, the bottle is semi transparent but the plate knocks it out?

As I said, you might try changing your transparency quality setting:


1 Like

Thanks Anssi you were right trans quality solved it!