Paint Tool in Sketchup Make 2016 in Windows 10

Hi. i have a square drawn. I click the paint tool . The Materials window appears, i click in a color or material and it doesn’t get it and the material still remains “default” and the paint doesn’t do anything.
Can you help me on that?

if the surface is already painted, and inside a ‘group’ context, the then you need to double-click into that context to change the visible surface color…

with a single-click, if you look at ‘Entity Info’ you will see a ‘group’ color change without the surface changing…

if not that, it may be your view settings…

john

Hi @lmfcruz61, if it is your view settings it could be View-Face Style, Monochrome checked.

Hello,
I have the same problem…

The Materials window appears, i click in a color or material and it doesn’t get it and the material still remains “default” and the paint doesn’t do anything. BUT I can use the materials, I already have used in the model - “in model” materials.

And what is meant by “view settings”? If They meant the View button and what is selected under it, I tried to select and stop every item.

Can anyone help me??
Thanks Polina

This happens to me all the time, drives me nuts. When i can afford to delete the surface and regenerate it with a line i do and it lets me paint it after this.

It would help if any of the three people in the thread with a problem would post a model where the problem occurs so we can diagnose the issue.
As it is its just guessing and most if us are thinking user error.

HI,
What exactly, do you want me to post? A picture, video or would you like me share you a file? For the last one I will need an e-mail. I’ve had this issue for a wile, even after the upgrade, and happens in every new document I start.

Why would you need an email. .skp files can be attached here.

Sorry, so use to Google drive…
Paint Problem.skp (98.7 KB)
I can not color the square…

Ok, so that rules out various user errors as I’m able to paint it any way I like.
If Lisanne, the painter, is fully coloured and you are unable to add colours to the square then there is definitely an issue.
Could be something like a permissions issue to your Material folder.
Is there anything strange about your installation?
Did you install as an Admin?
Are you working on a network drive instead of local?
There are many possibilities.

I have it installed on 2 different computers - one at home and one at work and share files between them via Dropbox.
I am the admin on both, working on local drive.
As I am not a professional, at first I had the 2015 free version and now I use the 2016 Pro trial version - had the problem on both. On the 2015 v it worked at the beginning and stopped, with the 2016Pro as it was upgrade it never worked.
The only thing I can think of at the moment is to remove everything except my saved files and to install it again.
Polina

I take it you can see other materials’ tiles in the window, but can’t select any that aren’t already in the model? That seems truly odd, as it makes no sense for SU to see the sample tiles yet not be able to load the materials… Sorry I don’t have a solution, just trying to help clarify the details of the situation.

It really sounds to me like a Material folder Permission problem.

NP, I can still use the program it is just frustrating… and I prefer to find a solution instead of uninstalling the program.
Yes, I can see all the samples but when I choose them nothing happens, unless they are in model materials.
I can get samples from the 3D warehouse and use them, and that is how i get my materials in the moment. If I can help with anything else…


Here is screen shot of the Materials window, you can see the color is selected, but the big material square does not change… If you click on Edit - everything is locked.

It really sounds to me like a Material folder Permission problem. - can you tell me how to check if that is the problem?

Very basic: I presume that you know that clicking on the colour in he materials docker fills the paint can tool with that colour - to apply it you then have to click on the relevant faces.
If you have multiple faces selected before using the paint tool, then clicking on one of these will fill all the selected.

(I am only mentioning this because from the above text it sounds like the user is wanting to select the faces, then select the color they want the faces to be - expecting the selection to change when the pallet is clicked.)

Actually, I have bigger problem… I can not select colors at all, unless they are in model colors.

Hi i read all the answers the problem remains… anyone found the solution?

You can’t edit materials on disk: those are write protected so you don’t lose original materials by accidentally overwriting them. In order to edit a material, you must first use it somewhere on the model. This places a copy of the material in the model’s In-Model collection. The material can be edited in the In-Model collection, only affecting instances of the material in the model, The material on disk remains unchanged.

-Gully