OS X dock icon launches a sub-process instead of itself


#1

This is a portion of my dock on OS X. (You’ll have to click it, since the important part is truncated by this forum).

The SketchUp icon on top was dragged into place from the Application file as a quick-launcher, just like every other icon on the dock.

However, when I click on it, it doesn’t launch itself, it opens a new instance of SketchUp on the dock, the one you see below with the dot indicator on the left. When I quit SketchUp, the bottom one disappears and the top one remains.

Obviously all the other apps on my dock behave normally, launching in place with a dot to the left to show they are running.

Really just a persistent annoyance… since I use the dock for quick app switching and their location is muscle memory for me. The SketchUp icon gets clicked a lot and nothing happens until I realize (again) that it’s somewhere on the bottom with other incidentally running apps.


#2

How did you get it into the Dock in the first place?

I find that if I drag the .app file from the Applications folder in Finder, that it launches SU ‘in place’ the way your other apps work.

You could try removing it from the Dock, and dragging as above.

But I have had other apps that behave the way you say SU does for you, so it may not be that simple.


#3

I tried it both ways with identical results:

1/ Drag the .app file from Applications/SketchUp_2017 onto the dock,

and

2/ While the app is already running, drag the icon to a new position in the dock.


#4

I’m groping a bit in the dark here. @slbaumgartner knows more about Mac’s internals than I do, and might be able to shed more light.

If you launch the app, then R-click on the running app icon, do you get an option to ‘keep in dock’? Does that make any difference to the behaviour?

And have you tried a general Google search for this issue?


#5

I’ve not seen that happen…I’d have to research it too.


#6

You didn’t drag it from the .dmg to the dock, did you? Mac’s Gatekeeper does this path randomization if you don’t install properly, and that’s what this sounds like. You can read more about it at https://9to5mac.com/2016/06/15/macos-sierra-gatekeeper-changes/


#7

Interesting idea, @Barry. macOS might not recognize the relocated code as being the same app as what was docked…


#8

I wasn’t aware of the 3rd way to dock an app that you just described.

For whatever reason, that worked!

So I had to run SketchUp.app, which creates two dock icons. If I right click / “keep in dock” on the second one, I can manually remove the first, then launch and task-switch from the second from then on without any duplication.

Doesn’t explain why, but it works. Thanks.


#9

I dragged SketchUp.app after installation. Good idea though. Still could be related to gatekeeper I suppose.


#10

Yea, it wont. It’s randomized. You can also fix via spctl (system policy control):

spctl --add /Applications/SketchUp\ 2017/SketchUp.app

See http://osxdaily.com/2015/07/15/add-remove-gatekeeper-app-command-line-mac-os-x/ for details.


#11

This topic was automatically closed after 91 days. New replies are no longer allowed.