Offset coplanar faces won't draw, very buggy behavior

faces_wont_draw.skp (88.1 KB)

I know everything should be coplanar because when I check the Z distance between any two points from shape to shape it says “0.00” without the ~. The inner rounded rectangle is an offset from the outer one. When I draw an edge on the outer one it creates a face, but the inner one won’t. Thing is, only some edges I draw on with the outer one will draw the face, some won’t. On the inner loop, no edges will draw a face, I’ve tested every one. I am drawing edges correctly, vertex to vertex, not to edge or guide or anything like that.

The outer loop is also not integrating onto the large rectangle face when I draw one of its edges that creates the outer loop’s face, so the rectangle’s face overlaps the outer loop’s face.

To make this extra wacky, on some off chance when the outer loop’s face is drawn, it’ll sometimes draw somewhere around 8 faces instead of 1 all overlapping each other, so if I delete the faces it’ll take like 8 deletions to get the face gone. I’m not sure if this happens when the big rectangle face is not involved, but the other quirks I’ve mentioned do happen when the 2 loops are just ‘floating’.

If I ctrl+a and intersect faces, some of the inner loop’s edges integrate onto the face, but some don’t and in addition it creates extra vertices on some edges, almost like it would if the Z distance was different between the shapes, but it’s not as evidenced by the 0.00 my ruler tool tells me between edges/vertices.

Sketchup sometimes just does this kind of stuff, there’s no way it’s intended behaviour. If it is, please help me not pull my hair out trying to work in this wacky environment. Thanks.

Sketchup Make 2017, all extensions disabled or uninstalled at the time of saving the project and verification of these findings. Extensions were enabled but were not involved during the making of the shapes.

This is not a SketchUp bug. It’s due to the way you modeled it. The ovals are not in the same plane as the rectangle. Note the Z-values in the coordinates marked in blue. The two on the left are from the inner oval and the ones on the right are from the outer oval. Those ovals aren’t parallel to the rectangle, either.

It would be difficult to see this with Display Precision and Units set as you have them. And you have Length Snapping enabled. That frequently causes problems. Best is to turn off Length Snapping and set Display Precision high enough so you can see errors if you create them.
Screenshot - 9_8_2021 , 11_21_39 AM

Here I’ve drawn a similar bit of geometry on the right side. The ovals are on the surface instead of floating above the rectangle. One ready clue is that the edges of the ovals are thin, not the thick profile edges as in your example.

1 Like

Absolutely the extra precision allows me to see it. I was under the impression that if it doesn’t show the ~ then that means it’s an exact value. That is ridiculous. Thank you for showing me that.

I actually had snapping to 0.36 on the project this came from, and the oval shape was created by simply extruding downward a 2D oval shape to create the bottom face which is what you see in the project, but the original shape was not distorted like this one at all. Cosmic rays maybe? :stuck_out_tongue:

I appreciate your help. I’ll adapt my workflow to account for whatever happened here.

1 Like

FWIW, having Length Snapping on and especially set to something coarse like you had it tells SketchUp that you don’t care about precise modeling. It’s a bit like painting with a big wide brush instead of using a very fine technical pen. And with the Display Precision set as you had it, you tun a blind eye to the discrepancies. By itself a coarsely set Display Precision has no impact on how precisely your model is created. It’s only limiting what you see.

I always work with Display Precision set as fine as it will go so I can see if I’ve got issues but. That doesn’t mean I want to or even can build things in the shop to that kind of precision. I do want to avoid potential cummulative errors, though.

What specifically happens with a coarse snapping length that causes variances in precision? Is it for instance like if I snap move a 2D square downward that each of its vertices may differ from one another? Or is it more like all those vertices snap the same length as each other, but snapping a different square may give a different set of values for its vertices than the other square’s vertices?

Is there no way to achieve an absolute value without entering the number on the keyboard? I just don’t see why those wouldn’t achieve the exact same thing…

ok, as for the technical explanation, this discusses a ton of snapping oddities and basically it’s a bit of an anomaly: Enable Length Snapping... Why? - #8 by Box

I guess my question is this: if there is no inference during a snap whatsoever, is the snap length as precise as if you were to have typed in a value? That’s all i want to know.

If the answer is yes, then I’m extra confused as to how my simple non-inferenced snap extrusion generated non-coplanar edges, and I’m even more frustrated by the fact that sketchup decided to fill the face which indicated to me it was all dandy but it wasn’t. If the answer is no, i’m still confused as to exactly why snapping alone would set a length different to typing it in even though they’re the same number.

Sorry for the rant, but this stuff just doesn’t make any sense at all and I’m astounded by the fact that it’s been this way for decades. It’s a fundamental part of modeling in this software and it doesn’t work, and I’m really perplexed by that.

edit: in addition, the original oval shows Z:0.000000 on all vertices, yet even that shape won’t draw a face unless only some of its edges are redrawn. I drew that face and extruded it hundreds of units upward to try and see if it’s some crazy far-right 32 bit digit out of wack, but no variance in X/Y between top/bottom as there would be if Z was off. there is just something else going on here. no_z_variance_still_wont_draw_sometimes.skp (80.4 KB)

I’m not defending the behavior but I will point out where part of your issue is coming from.
If you look at the entity info on your shape it is 61 segments, this is strange as you have three curves of 15 segments then a 9 and a 7.
The 9 and 7 are a 15 that has been ‘broken’ which has given it an extra segment. How this ‘break’ was created is probably the root of the issue, my guess would be that the edge intersected with something that was ever so slightly off, which made the two ends move infinitesimally so that the segments don’t actually form a straight edge any more.
You can see in the gif how the edges won’t repair when I add and remove an edge. (normally doing this will reform the edge)
Split segment

2 Likes

That is so weird, thanks for the insight.

i am legitimately smacking faces on each other that are 100% supposed to be purely coplanar and they just aren’t integrating. i am taking each of those faces and separating them, creating their face, extruding it thick, drawing a brand new 2D rectangle constrained to the z axis (100% perfectly flat, all vertices should have the same exact Z), and then intersecting each of the extruded shapes with this 2D rectangle. I then trim the geometry from those extruded shapes that are not the intersection lines. these new shapes must be perfectly coplanar, but no, they aren’t. they don’t integrate together. sometimes they do, sometimes they don’t, most times they don’t. i am doing everything right here. do i have a cursed installation?