Objects disappearing as I zoom in

Whenever I zoom into my object it keeps disappearing. I thought that whenever that happens is because the file is too far from the origin or there is something floating out in space far away. This is not the case and I selected all within the model, deselected my work, and deleted anything stray. My model is not far from the Point of origin. What gives?

It’s called Clipping - search the forum for that term. It’s a result of the way OpenGL works.

You can usually fix it by working in Camera/Perspective, Zoom Extents, and then going back to what you were doing. It’s more likely to happen in the first place in Parallel projection, so don’t use that for modelling, just for output of plans and elevations or sections.

In some cases, you need to restart SketchUp before you can fix the issue, but usually Zoom Extents is enough.

ah… yet another reason I need to learn Rhino faster. Thanks!@

The other cause of the same effect is when the camera is a long way off. You can have the camera zoomed into the model, and think that things are ok. Switching to Perspective would make the model seem incredibly small. Zoom Extents will fix that issue as well.

Your experience here will help you, because in Rhino they can have the same issue.

1 Like

I zoomed to extents several times but the issue is still occurring. I also switched back and forth between perspective and 2-point and this did not help.

Could we look at the file, to see if there may be some unrelated issue happening?

I’ve found that if the camera is sufficiently messed up, zoom extents won’t always fix it.

I had this problem with a modest sized model recently (only a few MB). Restarting SU fixed it, when Zoom Extents didn’t.

Good point, or if there is a rogue element way off in the distance.

It says the file is too big to upload, but here is a download link via wetransfer: https://we.tl/t-Tz3WhSxWjT

I am trying to model a bench now and the same clipping is occurring. I have zoomed to extents as well as deleted anything outside of my working space.

For context, I am modeling objects / linework on the flat surface above and draping items / objects/ linework onto the contoured surface below. Whether I am working on the top portion of the model or the portion underneath, the issue is still there. I have restarted sketch up and zoomed to extents several times now.

Try turning off the tag for the Location Snapshot. It covers a large area and makes clipping more likely when you zoom in.

FWIW, it would be a good idea to ensure correct tag usage and to purge unused stuff once in awhile.
Screenshot - 3_1_2021 , 1_38_55 PM

Screenshot - 3_1_2021 , 1_39_15 PM
That purge reduced the file size by more than 57%.

1 Like

I’m not sure exactly where you were working in the model so I can’t check specifically. But even before I made the same sort of changes as @DaveR described, I didn’t encounter any unexpected issues with clipping. By “unexpected” I mean that it is normal and correct to seem to move through surfaces as you zoom in on them in perspective - for example to go inside a room.

I used the CleanUp3 tool (I think it’s Thom Thom?) and reduced the file size as Dave R showed. If there is a better way to do this for future reference, let me know! I turned off the location as well.

If what you are mentioning is the case and it is trying to just move through the surface, is there a way to change the tolerance of when the pass through occurs? For instance, lets say I want to open this component of a bench slat and edit it to add finer detail, but it is clipping before I can “focus” on the facing slat of the bench. What is the proper way to achieve this given this inherent SU behavior

I can’t find that fence in the model you shared…can you tell me where to look? The image doesn’t look quite right to me to be clipping, it looks more like there is something in the way between the camera and the fence. Have you tried View->Component Edit->Hide Rest of Model to see if that removes the obstruction when you open the fence for edit?