Objects aren't solid

Hi, how do I make a object solid? I imported a lithophane I made with lithophanemaker.com and an other shape I made in thinkercad. I want to combine them with the union tool but both objects aren’t solid for some reason.
any help would be greatly appreciated

Can you upload the current Sketchup file you have with both these entities in it so we can see what you are working with?

I tried but the file is to big and i cant upload a compressed version
I will try uploading 1 entity

How big is it? You can drop box or google drive it and post the link. Did you try purging unused under model info >statistics? That might lower the file size.

I see you are a new user. There are some initial restrictions on posting to cut down on spamming. They get removed very quickly.

the file is 20.574 KB


no no 20 thousend KB

You need to make that open access so we can get in.

It should be so

That worked. Looking at it now.

thank you

Sorry, had to go help my son for a moment. This is of course a lot of geometry as is the nature of a lithophane. There may be tiny errors or holes in the mesh but it’s going to take solid inspector an age to go through all that geometry, I did not want to wait. Most slicers can tolerate some tiny mesh holes or internal faces and even merge adjacent groups. I made one component of your two pieces, and increased the size by 1000x, then set the model units to meters and exported a .stl for Cura. Cura has no problem printing this as it is.

how did you combine the objects

I did not. I simply exported the .stl of the file the way it is with the two groups adjacent to each. The slicer will merge them for you.

You could try to manually erase the top and bottom walls of the two groups respectively and put them into the same context to try to merge them but if your goal is to print this there is no need and working with this much geometry can be very slow.

thx a lot I didn’t think of that

1 Like

If you are using Cura, look for this option in custom print settings.

I use prusa slicer

Prusa has the same capability, not sure what it’s called. Might just work out of the box, it’s common enough.