Numpad keys as shortcuts on Razer Naga


#1

Hi, i have recently downloaded SketchUp Maker 2017 (Mac), my issue here is that i’m not allowed to use the numerical keypad numbers as shortcut on my Razer Naga mouse. i’ll give you an example of what i want to achieve,

for example i press: alt1 = line
cmd1 = extrude
1 = 1
i’ve tried to modify it on Sketchup Preferences > Shortcuts so wen i combine alt+numpad1 for line get error “key cannot used as shortcut”, is there a way to hardcode this shortcuts in a file?

thanks in advance


#2

While it is possible to manually edit the plist file that captures your shortcuts, I would advise against it. At best, you would do so at your own risk. Getting it wrong might crash SketchUp or, perhaps cause all your personal shortcuts to be ignored.

There are sound reasons why the preferences UI rejects certain keys as user-defined shortcuts. The cmd key is always disallowed for user shortcuts because it is hard-wired by the OS and the app for use in pre-compiled system and menu shortcuts. The raw number keys are not allowed because setting them as shortcuts would make it impossible to enter numbers into the measurements box. But combinations of opt, ctrl, or shift modifiers with a standard (top of keyboard) number key are allowed. If you can’t set modified keys from your numpad via the preferences dialog, I suspect it is because the OS itself doesn’t recognize those keys as ones that accept modifiers, that is, when you press alt 1 using the numpad, SketchUp may still see it as “1”. You could experiment with another app, such as a text editor or a keystroke monitor, to see what it receives when you press alt 1.


#3

This topic was automatically closed after 91 days. New replies are no longer allowed.