Notarize issue with my app

I’m trying to notarize my app with apple. If I include Sketchup API framework it fails and I get this error:

“severity”: “error”,

“code”: null,

“path”: “”,

“message”: “The signature of the binary is invalid.”,

“docUrl”: "",

“architecture”: “x86_64”


I have copied the SketchUpAPI.framework from the mac sdk, on a Mac computer.
(Can’t compile if you do this on a windows computer btw)

Is there a sdk certificate that has to be removed first?

What version of the SDK are you using and what version Xcode ?

The Windows edition of the SDK is not frameworked.

SDK is 24.0.483, not sure Xcode version but the devops pipeline is macos 12.

Off topic, yes I know. I meant if you download the Mac sdk on windows, unzip it and copy the framework folder to your repo. It’s messes up the symbolic links.

You do have the folder below "Versions" > "A" > "_CodeSignature"
with the "CodeResources" file ?

Hmmm … SketchUp still supports 11 (with the old OpenGL engine,) so try building to that.

Yes I have the CodeResources file in that path, tried removing it without success. Also tried building with macOS 11. Still no luck.

Okay, I’m not a Mac guy, but the last question I have is, you said you “copied” the framework.
Everything I read says to “link” to it. Is linking supposed to properly “package” a framework with your app?

pinging: @tt_su @bugra

My app is linked to the sketchupAPI framework, but a build step is also copying it to the bundle framework folder.
Like this: