Not Understanding Why Style is Affecting Parts Differently

Working on a table for a client.

Imported a leg from 3DW. In Sketchup, line weights visually look right for the table.

In Layout however, the parts I made have standard line weights from the style, but the leg line weights are not visually correct. Both of these images are from Layout.

Im assuming this is something baked into the leg, but I’m not seeing where or how to fix it.

Can you share the LO file with me so I can see what’s going on? Send it via a PM if you’d rather not share it publicly.

1 Like

Looking at the SketchUp model and I see that the edges on the leg component have the yellow mateial applied to them while the edges on the aprons are the default material. If you use a style with the Edge Color set to By Material, the edges on the legs will nearly disappear due to their color while the edges on the aprons and the top will remain black.


Very nice…that makes total sense. Good thing to keep in mind for the future. Didn’t have that in my brain as a solution. Thanks Dave!

You’re welcome.

Maybe mark my post as the solution instead of yours, though?

1 Like

my brain…oh the insanity!

1 Like

Another question…not liking that I don’t know this…

How did you select just the edges?

I used Selection Toys’ Select Only from the Context menu.

1 Like

update to this.

Rectified the edge coloring issue. Since I don’t have “Selection Toys” I reset the whole leg to default “No Material” by going into the component and selecting all the edges and faces and then “painting” with the “no material” texture.

I then existed the component and painted the leg with the proper color. Edges now show.

However, when I orient to an elevation view, Im seeing this…

The edges not showing all seem to be in what looks to be shadow regions if I turn on shadow. Not sure if that is why this is happening. ???

The edges that seem to be missing are hidden, not softened/smoothed. Here I’ve selected some of those edges. Hidden edges are shown as dotted lines with Hidden Geometry turned on. Softened/Smoothed edges show as dashes.

Here I’ve unhidden the hidden edges and then softened them. I also cleaned up the excess geometry. Where did you get this leg component? It’s got some weird geometry in it.

I’ve done a little more cleanup on it here.

I thnk it would make more sense to redraw it, though.

So, you are into the deep weeds with me now. Got the leg from the 3D warehouse. Obviously a mistake now. So much hate that one goes looking for models there and they mostly end up being trash.

How to clean that up is beyond my knowledge. Not seeing dotted lines. Everything is dashed.

As to making my own. Was trying to save time. Have a .jpg of the actual leg but working out how to translate that into Sketchup was going to be half a day for me. Now im at over half a day just working out this leg.

What I would be interested in is a tutorial and paying for an hour of your time to show me how to do this. Will DM you.

Have a feeling this was originally modeled in some other software and then exported as .skp file for the manufacturer to throw into the Warehouse. No one checked for errors before they uploaded it I would guess.

I think you are quite right. I found the leg component you used and it does need cleaning up. Simple enough to make a new cleaner one. I sent you a link to a screensharing session.