Not Responding for 15 minutes

On a large file (60 Meg) the program becomes unresponsive for up to 15 minutes and then returns. It doesn’t actually crash, and there isn’t a splat. This has happened about a half dozen times.
If I watch the Windows File Explorer, I can see that Sketchup is repeatedly rewriting the file to the drive.
This has happened several times.
Sketchup is also taking a long time to do saves, but that may just be due to the size of the file.
The system is a Lenovo laptop with an Intel core 7 processor and 16G of ram. The GPU is an Intel HD4400.

What is your autosave settings ?
Window > Preferences > General

Has the model(s) been purged of unnecessary materials / textures, component definitions and styles.
Window > ModelInfo > Statistics

Does checking the model for problems show any issues ?
(same dialog as previous)

You have 16GB RAM, but are you running 32-bit or 64-bit SketchUp ?
I realize there are often issues with integrated video drivers and the 64-bit OpenGL library, but if you can run the 64-bit edition, then SketchUp can use more memory (perhaps double what the 32-bit edition can,) for it’s process.


Have you run any diagnostic utility from the Harddrive OEM ?

Is Intel Rapid Storage Technology running with a green check mark ?
(It should have an icon in the taskbar tray area.)

Be glad, that You have a fast hardware ! Mine is same Prozessor and RAM but nVidia GTX 980 (Win7 64bit). The monitor shows that mostly only 1 core is working hard and only 60% RAM is in use.

My old PC needed many, many hours for the same files and mostly successfull.
The question is, why the monitor says “inaktiv” and Sketchup says “keine Rückmeldung”.

Same with old and new PC.

SU only uses one core for any geometry manipulation…

as with most software there are tasks that can’t be split…

Computers send a message when an app blocks the GUI for a short period of time, the app can chose a different message if it wants…

I have one that says “Put the coffee on…”

john

2 Likes
  • I’m running the 64 bit version of sketchup.

    • Autosave is set for a save every three minutes. Is it possible that
      the save is taking more than three minutes and is getting stepped on by the
      next save? I set it there because of the frequent splats. I just increased
      the time to 5 minutes.

    • “Fix problems” did not reveal any problems, but I run “tt_cleanup” on
      each group when I finish editing the group, so I did not expect to find any.

    • My other post about frequent splats may or may not be related to this
      problem. The splat problem persists. When the splats occur, the group that
      I am editing is corrupted (twisted and stretched). It is usually better to
      draw the part from scratch than to repair the group.

    • I have not had any problems with the hard drive, and Iobit disk doctor
      found only three minor problems which are now corrected.

I would say it is a good possibility.

Good, see if that helps. I was going to suggest increasing to 10 minutes. And then manually save whenever you think it’ll cost more time to redraw then to save. I’d suggest using a stop watch on a cellphone (etc.) to time the saves.

I personally find it easier to switch off autosave. I have always been in the habit of saving often, … whenever I make an edit I know I want to keep,… especially before leaving the computer.

1 Like

Any “heavy” extensions installed ? renderers ?

I’d suggest turning off everything except Dynamic Components. And see if the splats continue.

If not, turn on extensions one by one, until the instability returns. Note the culprit.

Well, on one of your machines you could try the 32-bit edition. If the splats cease, then you know your graphics driver has issues with 64-bit OpenGL.

It is a bummer, because that’ll cut the usable memory by SketchUp in half at least.

Upper right corner : “Keine Rückmeldung” means something like “no reply”, “no feedback”, “no echo” . In this case when I am importing a large STL (66 Mb).

This is my slow PC (Win8 / 4 Gb RAM) :

The “Not Responding” just occurred again. I have the autosave interval set
to 8 minutes and the program was out to lunch for 20 minutes. When I force
a save the program is busy for about 17 seconds. When this problem happens,
I can see the time-stamp of a.skp and a .tmp file being updated every
minute.
The good news is that the program only had two spats today. Both of them
when using the move command. In both cases the object being moved was moved
a great distance from where it belonged and was rotated as well. The system
goes busy for about 30 to 60 seconds when this occurs. Sometimes the rest
of the group is disrupted as well.

if your model is spread out over “a great distance” that may be part of the problem…

if things need to be that far apart, drawing and grouping a large rectangle underneath can help SU keep track and makes navigating easier…

if your just moving things out of the way, don’t, instead make groups, put them on layers and turn those off/on when needed…

a screen shot may help us help you…

I also never use Autosave…

john

My design is basically a cube 500mm on a side and filled with a 3d printer
mechanism. Components of the mechanism are nested in functional groups,
sometimes four or five levels deep. I sometimes use layers to hide parts of
the design so that I can clearly see what I am doing.
When I say that a component was relocated, I mean that it was suddenly
600mm from where it belongs. See attached.

that sounds like you need to reset the scaling on it and maybe other components…

if different items where modelled at different scale, then SU can get very confused even when orbiting…

the frequency of your Autosaving would not be helping…

60MB seems very large for any 3D printer model, have you purged the model recently?

john

http://www.thingiverse.com/search/page:1?q=CoreXY&sa= shows some complete 3d-printers (STL).

http://www.thingiverse.com/thing:1001065 (ca.20MB)

There’s an echo in here :wink:


What number of segments are you using on arc and circles ?

Are you drawing at full scale or 100x or 1000x ? There might be issues with small faces, etc. (SketchUp has an internal tolerance of 0.001 inch.) So this extra time “wheel-spinning” may be SketchUp choking on coincident points, etc.

It is often recommended to set the model units to meters, but think (and enter measurements) as if units were set to millimeters. Later when printing or exporting you can scale the whole model down 1000x.

1 Like

All components that I created were made starting with the same template.
Some components were imported from the 3D warehouse and I do not know what
the original scaling was. It is a very large, very detailed model.
How does one go about resetting the scaling of a component?
I have only seen splats when using the “move” and “push-pull” tools.

the Help pages tell you it’s a Right Click Context menu item…

Reset Scale
The Reset Scale menu item is used to remove any scaling operations applied to the component.

This menu item is available for the Component and Group entities.

but I think there are plugins that will go through an existing model and fix them all…

If your inside a ‘scaled’ context and try to inference something in a different ‘scaled’ context, then your actually asking for a huge amount of behind the scene calculation, which SU will set out to do…

it just might take a toll…

john

1 Like

"

Are you drawing at full scale or 100x or 1000x ? There might be issues with
small faces, etc. (SketchUp has an internal tolerance of 0.001 inch.) So
this extra time “wheel-spinning” may be SketchUp choking on coincident
points, etc.

It is often recommended to set the model units to meters, but think (and
enter measurements) as if units were set to millimeters. Later when
printing or exporting you can scale the whole model down 1000x."

This may very well be my problem. I am working 1:1 in millimeters. Some of
my component alignments are down in the 0.1mm range.

That would imply that most of the mechanical parts in the 3d warehouse are useless (well perhaps not useless, but need to be used with extreme caution). Most of them are drawn to various unknown scale factors and have to be resized to be the correct dimensions.

it usually takes a while for that to sink in…

I always import any into a separate file, evaluate the quality, explode, fix and rescale with tape measure using meters as mm then make a new component…

I more often just start from scratch…

john

Don’t you have to Window > ModelInfo > Purge Unused?