Not able to select a face on the wall/group

My aim is to create a door in the wall. The wall is a group.

My steps:

  1. Draw rectangle on the wall
  2. Push to create cuboid
  3. Make cuboid as group
  4. Move it into wall to to cut it through
  5. Select a wall and Apply “Intersect faces → with a model”
  6. Remove cuboid and select created contour/face but…

Here is the problem. I am not able to do this in any way.

Appreciate your support!


.skp file:
playhouse.skp (201.2 KB)

Some things to realize:

  • “Intersect faces with” always places the resulting edges in the currently open edit context. So, to cut the wall, you will need to have the wall board component open for edit before you do the intersection.
  • Since all the front and back wall boards are instances of the same component, you will need to make the ones you want to cut be instances of a new component else the intersection will put edges in all of them!

Thanks for the answer.
I was able to cut the wall but I used a lot of steps to achieve this.

Creation of cuboid, make cuboid as group, move cuboid through the wall, select the wall, intersect faces with, explode the wall/group, explode all planks from the wall, remove cuboid, remove piece of planks one by one…

Can I do anything to make it faster?

Probably. Share your SketchUp file with us so we can see the exact setup.

@DaveR Please check my first entry, there is skp attached, thanks!

OK. I thought you’d changed the model.

First thing I would do is get rid of the excessive nesting of components. That’ll make your work easier. I would also clean up the mess of unneeded edges in the model as shown selected copied to the left and selected here.

Then you can use Make Unique on the boards that get trimmed, open one of the boards for editing, draw a rectangle to the required width and use Push/Pull to create the opening. Not sure why in your model pushing to the inside face doesn’t eliminate the inside face and leave an opening but erasing the edges top and bottom takes care of it.


Actually I suspect the issue is related to having Length Snapping enabled in Model Info.

If you had SketchUp Go or Pro you could use the Solid Tools to do the trimming more quickly. Or better in SU Pro you could use Enroth Solid Tools to do it. This is with Eneroth Solid Tools in Pro.

1 Like

If you are wondering where all those stray edges came from, its when you used intersect faces with model. This made everything you selected intersect with everything else and form an edge wherever they came together.

It takes bit of time to get your head around the three intersect with options, but I assure you they do many sense (in about your 5th year of using them).
It is all about understanding ‘context’.
If you have two raw geometry faces intersecting, they are in the ‘same Context’ and as such when you intersect them the edges will join them and become part of the their geometry.
But if you have 2 cubes that are grouped separately, each has its own ‘Context’ and they are both in another ‘context’. So if you select those 2 groups and use intersect with model the edges will form wherever they meet, but the edges will be formed in the current ‘context’ which is outside both of the groups ‘contexts’. So you end up with the 2 original cubes and a bunch of stray edges.
But, if you open one group for editing, then select its geometry and choose intersect faces with model, you are now in the cubes ‘context’ and the edges will form within, allowing those edges to interact with the cube geometry. The other cube, being outside the current ‘context’ remains unaffected, and no edges form outside the context of the edited cube.

This probably sounds more convoluted than it should but it is often difficult to explain something that is really simple, but only once you understand it.

1 Like