No registration possible

So far I had successfully installed this viewer on my Samsung Galaxy S7 with Android version 8.0.0 and also used it for a long time.
From today it requires a new registration or a new account.

I thought, is not a problem. Sign in with Google Account.

However, the page simply stops in the login mode and the “hourglass” runs and runs and runs.

So uninstalled and downloaded again from Google Play.
Unfortunately still the same behavior: No progress to sign me up.
Also, the smartphone restarted, even without success.

My guess is that the cause is an update from Android. Because I had this about 4 days ago.

In the German forum I was advised to create a Trimble ID. I did that. But still the same behavior: I can not log in.
I’m asking for your help.
Thank you.

One thing about SketchUp Viewer for Android is that it requires Chrome to be active on your device. Chrome doesn’t have to be the default browser, it just has to be Enabled. If you go into the Applications menu, find Chrome and click on it there should be an “enable” option.

Let me know if that helps.

Hello Guz,
yes, your advice was the right one and helped me. On my smartphone, I disabled Chrome because I did not need it.
After activating I had to log in with the Trimble ID and immediately I could log in to the SU Viewer.
Thanks a lot for your quick help.
I will also pass your answer to our German SketchUp forum.
Best regards

1 Like

Thanks so much for passing the message on, PeterCzy!

The Chrome app being enabled worked as stated…who’d known?
Thanks a ton!!!

1 Like