No Preview Pane

I installed SU2017 this past March as suggested by another forum member while trying to figure out an issue I was experiencing on the laptop I had just purchased. Since doing so, I have opened it on occasion but I have really not modelled much of anything in that version. One of the main reasons is because I don’t like having to open every file just to see what it is - see the image below.

Was the Preview pane removed from SU? Since the “Open” window in SU2017 looks more like a window in the O/S - is this some quirk of Windows 10? Or, is there some simple setting I’ve somehow over-looked that would enable the Preview pane in the “Open” window of SU2017?

That’s not a thing for Sketchup include or remove. That’s the way your file explorer is handling files. Did you installed SU2017 correctly? That involves right clicking on the downloaded installer and choosing run as adminstrator?

From the icons you show File explorer is still using the ancient icon anyway. If it was showing the correct icon instead of the thumbnail it would look like this:
Screenshot - 11_14_2021 , 4_15_22 PM

I tested 2017 with a new file, and it did get the thumbnail. The SketchUp icon in the lower right corner was the 2021 version, it looks like Windows gets that from the application that owns .SKP files. It may be that SketchUp 8 still owns .SKP on your system.

For the icons not updating part of the problem, your icon cache may need refreshing. Here’s an article on how to find and delete that file, to give Windows a chance to rebuild it:

I tried the steps, and the thumbnails in the folder where my 2017 files are were rebuilt very quickly.

@DaveR
Though I had never done it on prior computers (b/c I didn’t know about it), all three versions of SU on this computer were installed using “Run as Administrator.”

As for the icons for SU8 and 2014M, I never had any issues before - including on the Windows 10 machine before this one. The appropriate icons opened the appropriate versions:

  • This icon 8 always opened SU8, and all .skb files created in SU8 displayed with this icon, and all .skp files created in SU8 displayed with a thumbnail .
  • This icon 14 always opened SU2014M, and all .skb files created in SU2014M displayed with this icon, and all .skp files created in 2014M displayed with a thumbnail

On this computer however (purchased early 2021), the icons for SU have acted stupid since day one - they display one way in folders, another way in the “Open” window inside SU, and yet another way in the context menus.


@colin
Thanks for the link to that article…unfortunately, it did not work for me.

Simply deleting (refreshing) the file “iconCache.db” changed nothing. So I went to the next step. I deleted the iconCache.db file again and attempted the rebuild, but -

  1. While I can pull up the Command Prompt in Run, only “Open PowerShell window here” is available in the context menu when shift>right-clikking on C:\Users\username\AppData\Local\Microsoft\Windows\Explorer
  2. The command “dir” worked in PowerShell
  3. The command “del iconcache*” did not work in PowerShell - access was denied. I do not know what command would replace the one the article advised to use, or if there is one

I just got this computer in March of this year…so the Windows 10 version may be different than the version the author of that article (dated 12/2020) was using, and could explain the hiccup.

Oddly however, the iconCache.db file has not returned yet, but still no thumbnails in SU2017M when looking for files.

The article I sent you to doesn’t mention command prompt or powershell. It said to use the folder options to show hidden files, and then you delete the now visible iconCache.db. You don’t even need to go into Folder options, the main File Explorer window has a checkbox to show hidden files.

I’ve always had hidden files and folders shown, so I did not have to make any changes there. I then deleted the iconCache.db file… but nothing happened. There were no changes. Because there was no change, I figured perhaps the icon cache was corrupted or Windows was unable to do what was expected, as described further down the article:

"If your icon cache is corrupted or Windows is not able to create the new image of replaced icon you need to rebuild or refresh the icon cache.

"To refresh the icon cache, just delete the iconCache.db file and Windows will automatically start rebuilding the new cache. (which I did with no result)

“Just do the following steps to refresh your cache icon. Go to C:\Users\username\AppData\Local\Microsoft\Windows\Explorer. Right Click on it with pressing shift key. Then you’ll see option” open command window here”, select it.”

I went on from there…