Files have no preview anymore

I was a sketchup 7 user. Recently I updated and downloaded the new Sketchup 2014. The problem is with this new version my files don’t show a preview anymore when I look at them in their folders even if it’s on thumbnail mode. Now I have to open each file to look for the model I need to use.

How am I going to make the files display the previews again? I tried opening the files in sketchup 2104 and saing them in the new version. Still no preview but the SKB file displays the preview.

Does this solution help?

My understanding is this command doesn’t work on 64 bit windows. It there some other solution for windows 10?

Apart from the fact this is 4 years later, thumbnails work natively in win 10.

Yes this is a new problem for me though and all the info and fixes are for 32 bit machines. My previews are showing .skb and not .skp file which just show an icon. I 'm pretty sure it’s an program association setting I need to tweek.

Fixed it. As I thought. Listed under the “open with dialogue” were two SU2017 icons. The files were already set to open with 2017 but they (skp) weren’t opening. I selected the “other” 2017 icon in the list and the previews started showing. I think the problem was created after a recent drive failure and replacement after which I had to reinstall 2017. But I’m guessing. Not sure why it shows two different SU 2017s in the list of programs.

Also in Windoze 7 there is a setting in File Explorer to enable the previews