New models in 3D warehouse don't have thumbnail


#1

So I’ve uploaded 3 new models in the 3D Warehouse. 2 of them don’t have an image of the model it’s just a plain green background and one of them is not fully in the thumbnail.
Here are the links of the new models:



What should I do?

thnx


#2

Hi @odysseas_ts

Before saving and uploading your models, ensure that the model is in the field of view in the SketchUp application. A quick way to do that is by clicking on “Zoom Extents” from the Camera menu.

3D Warehouse generates viewer and thumbnail assets from the position the camera was in the last time you saved your model. Adjust the camera inside SketchUp, save, then re-upload and see if that solves your issue.

Thanks


#3

No, it doesn’t work I even exploded a component and I upload it as a new component but still the same green backdrop…


#4

Can you post here or private message me links, and I’ll take a look?


#5

Found it. Saved camera shows exactly that. Do a zoom extents, and update your model, and the thumbnail will match it.


#6

Also be sure the Redefine Thumbnail on Save box is ticked.
When you have the model view set the way you like, create a Scene, then Save.


#7

@Geo
Thanks for chiming in here, but to clarify, the thumbnail setting you called out in Model Info should have no bearing on the thumbnail that gets generated on 3D Warehouse.


#8

Hi Mike,

I don’t understand.
Is it that there two thumbnail images, one local and one in the .skp file?


#9

The ‘File’ thumbnail is not displayed on 3D Warehouse. When a user uploads a model to 3D Warehouse, our Renderbots open the file and generate a thumbnail (actaully 2 of them, a low res thumbnail for search results, and a hi res thumbnail for the model details page) and that thumbnail is based on the last saved view.


3d Warehouse - model image
#10

Magic … !

Thanks Mike.


#11

Nah, it doesn’t work…
I did as you said, and I’ve tried it with many components and the camera is on top of them and saved!
I even reinstalled sketchup!


#12

@odysseas_ts, you’re wrong. I downloaded your model, and everyone who either (a) downloads your model (b) looks at the thumbnail of your model or © looks at the 3D viewer version of your model isn’t going to see it. Download your own model yourself if you don’t believe me, and don’t pipe in here until you’ve tried it. I did, and you’re wasting my time.


#13

For everyone else who wants to see this, it’s (Been Removed)

https://3dwarehouse.sketchup.com/model.html?id=u6ef1f815-bc1c-44d0-857f-ddac60c10142

You can see it in the 3D viewer at the top of this thread by clicking on ^ and then the top (Zoom Extents) icon if you want to save yourself the download.