New Build PC Experiencing Lags and Quirks With Sketchup and Layout- Help = Venmo'd Six Pack

Hey All,

First time posting, but long time reader. If somebody solves this I will venmo you a six pack, I built a computer recently when it became apparent that my laptop couldn’t handle the load of V-ray renders. My new computer performs like a champ rendering in V-ray knocking out images x15 faster than my laptop. My problem is the PC is very very slow navigating, and opening both Sketchup and Layout files. I use a program called Vectorworks as well and it is a little slow on that as well. I am at my wits end trying to figure out what is wrong with this thing. I have found myself doing most of my modeling on my mac that is top of the line from a couple years ago and it handles that same files and tasks so much quicker and efficient than this PC that should be much much more powerful. All other programs on my PC seem to be working just fine.

Here are just some of the weird quirks that happen on the PC, but not the Mac laptop on the same exact file:

-Exploding components can sometime take 5 seconds to 5 minutes depending on the complexity
-Opening actual files can take like 45 seconds
-some navigation and clicking lag - bad to the point that sometimes I can’t triple click to highlight everything because it doesn’t register it quickly enough
-general lag in layout
-if I try to highlight and delete a bunch of annotation it will freeze for a bit think about it and then slowly erase each annotation one by one

These are a few of many… and it absolutely brings the design process to a halt.

Some things that I have done are to set high priority to both programs for computing power and graphics card. I also know that it isn’t how I organize files and models, this happens on models of all sizes.

Here are the specs of my build, I work off of (2) 4k lg monitors as well if that matters:

I ran a benchmark on my computer and everything seems to be normal. The one anomaly is that when I run the benchmark with sketchup and layout open it always says sequential bench incomplete for the Samsung 970 Evo 500gb, could this be the problem? I’d post an image of the results, but the forum will only let me include one image as I am a new user.

Sorry for the long post, but I am about ready to throw this computer against a wall. Despite building the computer I am not great with windows and it was my first build, so if you think something might be hooked up wrong in the build please consider my a layman. I am much more proficient on a Mac. Whomever solves this I guarantee I will venmo you money for a six pack.

Thanks!

Steve

Standard things to check first:

  • Are your Nvidia drivers up to date?
  • In the Nvidia control panel 3D settings, is SketchUp set to use your RTX card?
  • In SketchUp, Window menu>Preferences>OpenGL, is Fast Feedback turned on? Is Antialiasing set to an insanely high setting?

Did you install using the Right Click Run as Admin method.

Please fill in your profile with the relevant information so we don’t have to go hunting for this thread next time we need to know the basics of your system when answering your questions in future.

Thanks or the response!

I check the nivdia drivers are up to date.

It seems that Sketchup and layout are set to use the card, do I need to customize any of the program setting?

Fast feedback is on and the Antialiasing doesn’t seem ridiculously high

Yes I did. In reply to your other comment apologies, not sure if I can change it now, but will do so in the future.

Thanks,

Steve