Need help with .wrl

Hi Guys

Looking for a bit of advice here. I have been using sketchup for a decade as a fun way for building furniture and hobby modeling.

I have now upgraded to pro as I am using it more and more in my work. I am now working with a supplier who is designing light gauge steel framing for residential housing. I asked them to share their model with me as I want to import it to my master model of the house we are working on. It is a .wrl file.
I had them send me a sample before to see if I could do it, and I did. I used a file converter, ctrlview, and changed it to a .dxf file and it worked perfectly. I now have the first draft of their model and this converter is not working. I suspect because the file size is much bigger. I spent the day looking for anything to open this file but to no avail. I tried freecad, meshlab, blender, and nothing worked. I suspected the file maybe bad, but then SAP visual enterprise viewer opened it and there was the model in all its glory. The viewer unfortunately does not give you the ability to save as another file format. I am curious if anyone has any experience or advice to help me. Please be patient as I am a construction worker and not a computer expert. I’m pretty sure there is an easy way to do this but it eludes me.

The designers are using Framecad detailer, if this helps.

Do they offer a more universal file format like .IFC?
You could use Trimble connect to share projects, it is designed to work with different software/contractors/etc

Thanks for the reply. I will be talking with the designer tomorrow to see if he will be able to maybe convert it to a file format I will be able to work with

1 Like

You might also try MeshLab Import WRL and export 3DS, DAE or DXF to import into SketchUp.

1 Like

Thanks psaal. I have tried mesh lab but I haven’t had any luck opening the file. I’m also not to familiar with Mesh Lab so it can very well be on me. I get errors which are totally Chinese to me.

can you upload the file?


Here is a link to it as this forum will not allow me to upload a wrl.Palm Lake House
Thanks John

it opens in, but that only converts to the updated d3x format…

try it in MeshLab…



Didn’t work for me… :frowning:

did you unzip it first???


Hey John

Thanks I gave it a go and I received this error.

yup. Extracted to X3D file format. Are you able to open it John?

the space in the filename was stopping my converter…

I looked for every other issue first… (2.6 MB)


1 Like

:+1: :slight_smile:

Wow John

Thanks a million. My first time here and you guys really helped me out. This was great. Thanks again. Much appreciated.

for the record,

I used view3dscene to get the x3d and then Assimp from the command line to convert to .dae, for import into SU…

both are free and cross platform…


1 Like

Thanks.:+1: will be using this method.

Help me please.
I have the same problem. I can not convert files .x3d to .dae…
Tell me in detail how to do it. Next, I’m going to convert to .skp that use in ECDesign.
This is my first experience with 3D models.

maybe @jim_foltz can assist for the windows instal of assimp…

I use ‘Homebrew’ on my mac…


There’s no official Windows binaries or installers for assimp as far as I know. I’ve attached a recent version the latest assimp for Windows 64 executable.

You’ll need to move the 2 files to a folder in your PATH environment variable, or to the folder you are working in.

To convert a file on the command line:

> assimp export input_filename.x3d output_filename.dae

That’s about all there is to it. type assimp help for assimp features and options. (2.4 MB)

1 Like