Need Help - My Model Disappeared

I was using the soap skin/ bubble tool and then my model glitched and all I can see now is the gray floor color.
I had used the extension a few times successfully before the glitch.

I tried viewing guides, orbiting and zoom extent and nothing works.
I tried the select all, copy and paste in a new file… didnt work either.
I looked at the model info and there are things still in the file, I just can’t see them.

I have read some forum chat about using ruby console to look for bugs and infinite dimensions but I don’t know where to even start with that.

Can someone help me please?
Fort Martello.skp (7.1 MB)

hello, can you attach the file ?

1 Like

It is now uploaded on the original post

Fort Martello.skp (1.2 MB)

1 Like

Ah!! Thank you soo much! Is there something I did that can be avoided in the future? Or a simple fix that I should know of?

I expect you had some label or something attached to something you deleted which sent the label off to the far reaches of the universe. I ran a little plugin that chugged away and sorted it out.

1 Like

I am facing a similar problem with my file. The entire model has just vanished but there are items showing in model info. Please help me in getting my model back.
Blocks 3D_1.skp (2.8 MB)

This is what I see after fixing your model.

I also fixed incorrect tag usage.

And purged unused stuff from the model.
Screenshot - 6_1_2021 , 4_58_49 PM
For about 27% file size reduction.

Blocks 3D_1 fixed.skp (2.1 MB)

Thank you so much. It really saved me a lot of time and energy.