My imported components have gone all funny

Hi there. I have been working on a floor plan but suddenly most of the components I downloaded from 3D warehouse have gone all funny with dashed and dotted black lines all over them and boxes around them. Is there a way to get rid of these lines? Please help if you can.
Thank you.

Go to the View menu and turn off Hidden Geometry.

Hidden Geometry on:

Hidden Geometry off:

Thank you so much Dave!!! I am new to sketch up and all these little things trip me up! I really appreciate your help. Have a lovely day!

1 Like