My default Tray is not following my Preferences

I have updated to Sketchup Pro 2023. I have set my Preferences for the location of various files such as Components and Materials and the Default Tray is ignoring theses and using the files for these items that originally come with Sketchup. How do I fix this?

If you look closely at the Preferences box, you will see a small square with a pencil in it. Click on it. Do not be afraid to click on various items in these windows to see what they will do.

I think that I worked this out. I found the location of the default folders for Materials and for Components and I deleted them. Then when I opened the default Tray, I selected my folders for Materials and for Components and added them as the favorites. It seems to have worked. Thanks.

As you can see by my attachment, I had already selected the preferred folders in Preferences, but they were not recognized by the default tray. See the solution in the post today. Thanks