Multiple overlapping faces

Hello, I have a problem that repeats itself in all versions since 2020.
Sketchup produces multiple overlapping faces when the face is edited

After a lot of effort and research, I found that the only solution for this is by moving the entire model each time to the origin of the axes in the area I am working on in the model - something that greatly delays the work. Very frustrating - I’d appreciate it if someone has another solution to this frustrating problem. Thanks

Are you talking about problem described here in a bottom part of the article? : Flickering Faces in your model

What does it mean:

Can you share and example of your model (.skp file) and explain it more with screenshots?

No, it’s different, I’ve also had this issue with some models, there’s no flickering, I just noticed because I deleted a face and it was still there, I had to delete 4 or 5 times to finally see the hole. Solid inspector detects it but can’t fix it, it actually makes a mess cause it detects as reversed faces and it reverse some faces adjacent to the overlapped faces, the only solution that I’ve found is to delete them on by one or dragging the mouse to select them all at the same time, and I use curviloft or kbs face tool to make a face on that hole cause if I draw a line, all the faces will be created again. It’s not a problem of multiple overlapping lines, I’ve used vertex tools to verify if I have more vertices than the ones I should.

It is interesting, I never seen something like this (- yeah, I modelling much less in nowadays :blush:)

I really want to see such a model… Do you have some? Or in which conditions man can reproduce the issue?

I have no idea how to reproduce this, I’ve tried but with no success, I haven’t had this issue recently and I can’t remember a model and the part of the model to make a video it’s something that has a fast solution so and not so frequent, at least for me, probably the OP could make a video or share the file.

1 Like

I’m just now importing a png file, a picture of fabric straight from the purveyors website. I was able to import it, but of course I had to scale it.

I used the same method as importing and scaling a 2d floor plan. I was able to rescale it, that way. However, I am unable to release the X-ray view but still have my fabric.

I’ve tried to copy, copy and paste in place. No luck.

Youtubes show I should be able to import it and scale it, but I wasn’t able to do it to the PNG file.

Any input?

You can scale a png with the ‘Scale’ tool by scale factor.
To scale to precise desired dimensions you’ll need to (if isolated from the rest of the model is desired) do so in editing context inside a group.

  • right click on the png and select ‘Make Group’
  • enter this group and measure a length (‘Tape Measure’ tool) that you know the dimension of
  • immediately type the right dimension and hit [Enter]
  • answer Yes to resize the group’s content
  • close the group

b.t.w. your question is off topic here.

Thank you, I am attaching a sample file + explanation -
please try drawing that line\ face and see what happens- in the blue or yellow area in the red circle.

I am a long-time SketchUp Pro user - more than 15 years on a daily basis
In my opinion it is a matter of the version of sketchup in the previous versions before 2020 there was no problem with it.
The problem exists in all the computers I work on.
Takes up a lot of time and is exhausting - you just can’t function like that…

Multiple overlapping faces.skp (1.1 MB)

It is not really a flat surface.


Here you can see the difference after using a flattening extension.
GIF 16-11-2023 7-29-20 PM
So the question is, how are you creating your geometry to cause it not to be flat?


Hi, thanks a lot!
I don’t know why this happened… I’ll try to find out…
What extension do you recommend for flattening?

I use vertex tools to flatten faces parallels to any axis or make coplanar faces not aligned to an axis, you can do a lot more with that plugin it could be overkill for you, but you can give it a try if you want. I’m not sure what plugin used Box.