Moving a surface


#1

I am trying to modify the bottom surface of this thumb nut screw
( http://www.thingiverse.com/thing:932390/#files ) because it currently is too high for my purpose…
How can I reduce the hight by 2 mm without interrupting the smooth radius around the edges?
When I try tu push it says “offset limited to 0.0000mm”


#2

Open the ModelInfo window, switch to the Units panel.

Is LengthSnapping checked ?
What is the setting ?

Also what is the unit precision setting ?


#3

Wow that was a crash course !
No, Length Snapping was not checked. Says 0,000001mm
Precision says 0,000000 mm
I guess they are default. At least I did not change them or do they come with the imported model ?

I wonder what I am doing, quite new to Sketchup.


#4

You need to Move all the geometry you want to preserve, not Push/Pull only the top face.
Like so…

• Camera > Standard Views > Front
• Camera > Parallel Projection
• View > Face Style > X-Ray
• Use a Left to Right Window Selection to select the geometry you wish to move.
• Then use the Move Tool + Up Arrow Key (locks the move direction to the vertical blue axis)



#5

Some options: you can open in SU and scale , you have to install the stl plugin or you can download the netfabb free app from shapeway and also scale which allows you to open directly in stl .


#6

They are likely set by the template you choose in the Welcome dialog (or the Preferences dialog > Templates panel.)

So display precision is set to 6 decimal places.
Length snapping is off. (You can toggle it on & off as you need.)
0,000001mm snap length is a bit small, as SketchUp’s internal tolerance is 0.001" (0,0254mm.)


#7

Thanks Geo
That was a very good and easy way to do it !


#8

mac
If I scale it wont I scale all of it ?


#9

Dan
Parden my ignorance but what exactly does Lenght snap do ?


#10

Set it to something realistic like 1mm, and then try drawing an edge with it on and then off. You’ll understand.