Move Fails to Stay on Axis Even When Locked!

movetool
autofold

#1

Original Title: Geometry fails to fold on line

This seems like strange behavior, I can’t seem to model the haunches on this box culvert because the autofold is breaking the model. Maybe it’s just me?

AutoFoldFail4x4 Box Culver Low Cover.skp (141.3 KB)

If it matters, I made the geometry with follow me to create the bell and spigot joint.


#2

That line isn’t breaking the face. Notice it is a profile edge. If it was breaking the face into two faces, it would be thin. Redraw that line and make sure both ends of it intersect the edges of the face. It wouldn’t hurt to delete those softened diagonal lines while you’re at it. They don’t really add anything.


#3

Any idea why that is the case? Shouldn’t the moved line be coplanar and break the face? Intersect didn’t even work, I had to delete the line and draw it from scratch. It seems like this method worked for me in the past.


#4

I don’t know how you drew the line in the first place but if it intersects both edges of the face, it would divide the face and the edge wouldn’t show as a Profile edge. It’s 0.006363 in. shy of meeting the edge on the side where the blue and green axes are. I expect it comes from having Length Snapping enabled and precision of only 1/16 in.

Here I’ve set the precision high enough to show how much short of the edge you are.


#5

That’s wild. I option+ moved the line to duplicate, inferenced the green axis, hit 8 for the distance, and hit enter. The entire structure was made with a follow me around a 48x48 square, which was drawn locked to the red plane. I don’t understand how the line (or I) came up short, so to speak. I’m going to pull an intersection of the profile and do it again in a new file to see if I have the same result.


#6

I neglected to look at the other end. Evidently you didn’t move the copy exactly on axis because the other end overhangs by the same amount.

When you move the copy of the edge, follow the perpendicular line.


#7

I thought that was what did that in the first GIF? It had the fine green dashes showing when I typed 8 and hit enter.

Let me start over…
AutoFoldFail2
AutoFoldFail3
AutoFoldFail4
AutoFoldFail5
AutoFoldFail6
AutoFoldFail.skp (132.6 KB)
Even if I lock to green it still is off.


#8

I don’t know what you’re doing differently. I’m not having any difficulty. Try disabling Length Snapping.


#9

I believe you! I’ve restarted SketchUp, I’ll restart the Mac when I get back from lunch, no point in trying to fix this on an empty stomach.

And I did get it to work by hand drawing it, moving the line with inference should work though. This seems to be something worth figuring out. I tried disabling length snapping.
AutoFoldFail7


#10

You might also set precision higher. I don’t want to work to 1/64 in. in the shop but I set fractional precision to 1/64 in. in SketchUp so it’s easier to find little errors and such.


#11

Sady, no, didn’t help.


#12

This is crazy, it’s still doing it!
AutoFoldFail8


#13

Are you sure that little nub was not still there from a previous erased attempt? I’ve been trying to re create the situation using your file but I cannot get it to do anything unexpected. In your last GIF does the line bisect the plane?


#14

I see it happening in your GIF but I’m sorry, I just can’t duplicate the issue without actually trying hard to do it.

Try hitting Option right after getting the Move tool and before grabbing the edge. That is one thing you are doing differently. You also don’t start out moving on axis.


#15

In your last GIF. You click to start the Move, then lock to Green, then click to place the line. BUT, then the line moves again after that.

I don’t get what you’re doing at that point for it to move again? Can you explain exactly how you do the Move?

EDIT: If you are typing measurements after the second click then pressing Enter, yes that works for me. In that case ignore me. I normally start the Move then type the measurement right away and press Enter. I can’t seem to get it to fail any way I do it. Its a puzzle.


#16

Yes, I double checked before the move. It’s weird.

Yes in that case, and that is normally how I do it as well.

So I did this…and now it works no matter how I start it. So it’s fixed? I hate anomalous errors.

Thanks for your help everyone!


#17

I think it’s the way you started the Move/Copy operation and where the copy was when you locked the direction.


#18

Clearly a space-time anomaly. Probably Tachyon Particles, or solar flares, or maybe it was all part of super villain @DaveR’s nefarious plan.