Move (contours) not locking to z axis


I see this question has been asked in previous years but can’t see the solution that works for me.

I have imported a 2D image with contours that I would like to turn into a 3D terrain model. I have sketched around the contours using the free hand line tool.

The next step, which should be easy, is to lift each contour to its designated height. However try as I a might I can’t get the lift to constrain to the Z axis.

Moving constrained to the X and Y axes seems to work just fine, I only need to nudge in the general direction and the inference takes over, but it refuses to do so in the z direction.

Tapping the up arrow, as most instructions suggest leads to a stretching operation - I can’t tell if this is just the individual contour component or whether it’s interacting with the surface of the next contour below.

The ‘Unglue’ option, which seemed to solve this issue for others seems to be unavailable, and have tried plugging in a different keyboard in case a key issue with the up arrow, but same problem persists.

Any help much appreciated!

1 Like

Thanks mihai.s

Deleting the surfaces that were automatically created when I drew the free hand lines seems to have solved the issue.


The important part of the screen recording is pressing Alt while trying to lift the contours. That triggers the auto-fold, that is needed in order to create the extra faces.