Mouse clicks unresponsive

Hey folks. First post so be nice to me.

I’ve been using Sketchup web for a few moths now for a workshop project I’m doing and it’s been great.

For the past few days however there seems to be some sort of server lag happening all the time. When i try to measure the distance between two points, when i try to move an object, pretty much anything, i need to click serveral times for the click to register. For example when measuring i click on the start point but it doesn’t register the click.

I thought maybe my model had grown too big but i went back and tried on smaller projects previously and the same thing is happening. Even when i start a brand new project it happens.

Thankful for any ideas.

Cheers!

Do you have mouse issues while browsing the internet or in other applications? What mouse are you using? Is it wired or bluetooth?

I’m using a wireless mouse, Logitech MX Master 2S connected via Bluetooth. It’s worked perfectly before and continues to work flawlessly with all other applications.

I’ll try with a wired mouse to see if the problem still exists though. Thanks!

Yes lack of response is the same with a wired mouse.