Models viewing problem (3d Warehouse and MobileViewer)


#1

Why uploaded skp files looks transparant, when they are not ?

  • same problem on 3d Warehouse viewer and Sketchup MobileViewer

#2

Are they not? If you could share the model (or a simplified example model), one could see how the model should look like. And maybe one could get an idea what could trigger the wrong behavior of the viewer.


#3

Thank you, I checked again - in fact default meterial from template had slight transparency. Solved :slight_smile:


#4

I’m afraid that’s not possible. The default material for face fronts and backs, selected on Styles > Edit > Face Settings, may be a solid color only. No textures and no transparencies.

Are you sure you didn’t simply paint those faces a transparent color?

As Aerilius mentioned, we can take a look at the model and try to see what’s going on, if you wish.

-Gully


#5

? hm, I’m surprised what you saying.
100% model was not painted any transparent. I did checked whole structure of model down to elements in the group.
But in Style palet / edit / face setting, I can modify kolor of front and back color! including slider of transparency!
This where I found that front color was 83% transparant.
After correction back to 100% , I loaded on 3d warehouse and now it shows ok.

(Model I cant make public, sorry)


#6

Tomek, take a look at this thread from last week:

-Gully


#7

I’m not sure that understanding corectly Lucian’s problem, but i can say that if I want something transparent - I do create new material, I edit it in color palet (edit color by double clicking on color icon) set transparency to level I need and save it. And later on - if I want modify level of transparency I edit again , given color/material in color pallet.


#8

So SketchUp is not designed that default colors can be rendered with opacity. Nevertheless the UI on OS X allows to change the stored value for opacity (as well as the Ruby API does). Since the value is stored in the file and also exported into the mobile format, it seems the mobile viewer does not ignore it.


#9

Looks like.
And this is a problem.
In other model, I have almost similar problem transparecy is atributed somewhere somehow, but it dose not show on screen when working - it only shows on viewer (mobile) and all is all black screen when viewing in 3dwarehouse viewer.


#10

Well, Tomek, it sounds as if we’re both right. In recognition of this rarity, please take a moment to enjoy this delightful and apposite quotation from Kurt Vonnegut, Jr:

On the Chronosynclastic Infundibulum – Just imagine that your Daddy is the smartest man who ever lived on Earth, and he knows everything there is to find out, and he is exactly right about everything, and he can prove he is right about everything. Now imagine another little child on some nice world a million light years away, and that little child’s Daddy is the smartest man who ever lived on that nice world so far away. And he is just as smart and just as right as your Daddy is. Both Daddies are smart, and both Daddies are right.
Only if they ever met each other they would get into a terrible argument, because they wouldn’t agree on anything. Now, you can say that your Daddy is right and the other little child’s Daddy is wrong, but the Universe is an awfully big place. There is room enough for an awful lot of people to be right about things and still not agree.


Textures missing
#11

It must have been saved wrong in the template. Open your template (File → new) and fix the setting, then File → Save as template (overwrite the same).

To fix it in existing files, open each and either do the click-click procedure (Style → Face Style → Front color), or open the Ruby Console and paste once:

ro = Sketchup.active_model.rendering_options
["FaceFrontColor","FaceBackColor"].each{ |key|
  color = ro[key]
  color.alpha = 255
  ro[key] = color
}

You can repeat the same in new files with two keys presses enter.