Modelling Issues

I have been trying to get used to using SketchUp for Schools after years of happily using Make and Pro but I am having nothing but grief.

While trying to teach a class today I made a rectangle and tried to push/pull it to 18mm. Every time I entered the numbers it would ignore the 1 but 8 would appear in the dimensions box and it would partially create a solid without a top surface. The height of the push/pull was neither 8mm, nor 18mm. Eventually I gave up and used the tape measure tool to set an 18mm guideline and pulled it to the correct height but something is not working properly.

I then tried to copy/rotate a group. I selected it but got the wrong axis so hit ESC as I would have on Make or Pro but the whole model disappeared!

I then wanted to copy 2 groups and so selected one and used CTRL to add to the selection but it automatically added all of the individual groups to the selection so I had to copy and move them manually.

As I said at the beginning, I’ve been a user of SketchUp for years, probably 10 years, and have always loved the programme. This new version however is quickly driving me demented and will turn me and my circa 200 students per year away from SketchUp.

Have you tried another keyboard? All your troubles seem keyboard related.

Is ‘Length Snapping’ still on?
If so, be sure that it is off. Your template in SketchUp for School might still have it on to some inappropriate length.

The keyboard is fine. Works perfectly everywhere else.

Where do I find that option? I don’t see any Options or Preferences button.

The ‘Model Info’ button down on the right side: ‘I’
That takes you to where to “correct” (display!) settings etc.

Thank you, got it. I’ve tried it and the same problem is still happening.

I know it is a pain to adjust your mind to work with the different UI in the web version if you come from the (any) desktop version. But you’ll grow to like it in the end. With still some drawbacks though.

1 Like

Which browser is used to run the web version? (for others that know more about these things!)
I use Chrome, latest update. No problems.

I’m on the desktop app on Windows 10

Fair enough to get used to small differences in the UI but this is more of a functionality issue as I can’t extrude to a specific dimension.

Selecting the right axis can be done with the [Arrow] keys:
left = green
up = blue
right = red

down = constrained to face (magenta color).

drag along an edge (for example) = use the edge as rotation axis

I don’t know about the disappearing of your model.

Thanks. I know all of those tips but appreciate the help anyway.

You are quite right and there must be an explanation!

This is a contradiction. If you are in the desktop application then you should have the interface, that you are use to it. But you told us (and in your profile as well) you are using the web app.
To be able to use web app you first have to start a web browser i.e. Internet explorer, Microsoft Edge, Google Chrome… then go to https://app.sketchup.com/
So which one are you using?

Basically in Windows 10 you (could) have:
image

Try to use the Microsoft Edge marked with green rectangle. But as above suggested, maybe better to get Google Chrome, since this one a most recommended.

I’m sorry but this is not a contradiction. I am using an app, downloaded onto the pc, 47.2mb in size. Where did I say I was using the web app? And where is it in my profile?

Apologies, I see now (web) after the sketch up for schools in my profile. My mistake. It is the app I am using.

1 Like

But still SketchUp for Schools is a Browser-based SketchUp.
I have no access to try but I guess that can be a problem if it is launched not in a right browser in some reason.

Can you just try run a Microsoft Edge or Google Chrome and go to https://app.sketchup.com/ and see how this app behave for you?

My understanding is that it’s an app, not running on any browser, connected to my OneDrive.
I’ll have a look at the web based version you’re suggesting.

https://help.sketchup.com/en/sketchup-schools/sketchup-schools-system-requirements

image

https://help.sketchup.com/en/sketchup-schools/getting-started-sketchup-schools#understand-need
image