Model Seems To Be Missing Elelements


#1

Hi,

I am working on a very simple model - a bench. What is happening is that when I open the model it shows me all that I have in it.Dining Bench2.skp (742.8 KB) When I choose other scenes, or when I make a new scene from what I am seeing, the model changes as if many of its components and groups are hidden. Unhiding All does not solve any problem. It looks and acts like many of the components do not exist while if I close the model and reopen it I will see all the components that there are in it.

Is the model corrupt?

I’d like to add the model to this post but do not see a way to do it.

Thanks

Farzad


#2

To upload the model, click on the Upload button (7th from the left above the text window when writing a reply. It would be easy to give a definite answer with the SKP file to look at.

Very likely the problem stems from using Hide to make components/groups invisible for certain scenes and then not updating the scenes after unhiding them.

You shouldn’t be using Hide that way, anyhow. That’s what layers are for. Hide is intended as a temporary thing.


#3

Thanks. Dining Bench2.skp (742.8 KB):


#4

Yes, I do use Hide as a temporary command when I want to get some things out of my way so that I can edit other things. I have been using that practice for a while and this is the first time a problem like this has popped up.

Farzad


#5

Got it.

So yes, you’ve used Hide to hide some parts. With Hidden Geometry turned on, you can see them in the first scene.

Well, if you use Hide like that, hide things and then create scenes, those scenes are created with those entities hidden so when you return to the scene, those things will be hidden. If you don’t want them hidden in a specific scene, unhide them and then update the scene by right clicking on the scene tab and then clicking Update.

It would be better to create layers for the various components and then turn off visibility for the scenes as needed. You can still use Hide for temporarily clear away the clutter.

By the way, you should correct reversed (blue ) faces as you go.


#6

What’s happening is that you have hidden elements inside nested groups. You have to open the group to unhide contents. Stated another way, “Unhide All” only works within the current editing context, it does not reach into other groups or components. This is one of the reasons why most experts advise you to use layers instead of hide to manage visiblity. It is too easy to miss this kind of subtlety.


#7

How do I do that correction?


#8

It is strange since I know for sure that I do not hide anything while inside a group. In fact, I group things together, get out of the group mode and then hide them.

I went ahead and unhid them in Group edit mode and things are getting better.

Thanks


#9

Thanks for the help.


#10

In your hiding process you’ve not only hidden parent groups but the child groups with in for one of the groups.

I’ve unhidden the hidden stuff and updated the first scene.


Dining Bench2.skp (753.1 KB)

Which correction? The reversed faces? Open the groups for editing, select the faces and right click on them. Choose Reverse Faces. There’d be less work to do if you’d used components instead of groups.


#11

You had hidden groups nested inside outer groups. You have to get into the context where the hidden entity lives to unhide it.


#12

…accidental. Thanks for the diagnostics.

Farzad


#13

I took the liberty of fixing up your model. I corrected face orientations, converted parts to components, and made a second leg assembly. I also correct the way the seat parts were painted and purged a bunch of unused stuff which, along with using components, cut the file size by more than 50%.
Dining Bench2.skp (302.2 KB)


#14

Dave, thanks very much. I will download the new model and explore for all the god things that you have done. I don’t understand why faces have to be corrected regarding their orientation but I will look into it. I suppose there are outside and inside faces?

Farzad


#15

that’s our dave…