Model not visible

I just opened up a sketch-up file of a model I have been working on and nothing is visible.
I am using SketchUp2021 version 21.0.392 on a MacBook Pro.
I have tried:…

  • Zoom Extents
  • Edit Unhide All
  • View Edge: Style, Edges are checked, Profiles are Checked
    I am using Style “Simple Style”
    In Outliner, all my components are listed but greyed out. If I click one, the blue outline box appears but there is nothing inside it.

I use the LightUp extension and when I click “Go” the model is all there and beautifully lit.

What is going on? How can I get back to editing my model?

oh… just tried one more thing… I opened the back-up file of the same model and it is all there and working… phew!

Still puzzled about what went wrong though.

Philip

.

Tags turned off? Did you add something that lies at an astronomical distance from the origin point?
Post the model if you can.

The symptoms you describe are consistent with tag visibility turned off.

You are exactly right. All tags were turned off. Mystery solved.