Model missing from home (Model storage provider initialization failed)

I can see my model being loaded in the start screen (spinning animation) and then it’s gone and replaced with a ‘welcome to sketchup: start modelling’.

Yesterday i wanted to work on my model, when there was some message about Trimble connect issues. So today i logged in again, but still no model.

When i click on Trimble connect it states ‘Something went wrong trying to load this folder.’ When i check out the browser inspector i can see another message in the console:

ERROR: Model storage provider initialization failed.

How can this be fixed?

1 Like

Hello, peer1979. I’m sorry you’re running into this problem and we appreciate you reporting it. Since I see you are familiar with your browser’s development tools, would you mind taking a screenshot of any errors you are seeing in the network tab? There seem to be a few folks experiencing this but so far we have not been able to identify exactly what is happening.

In addition to answering Paul’s questions, could you log an issue directly with Trimble Connect? The more reports they see the better chance of figuring out the problem. You can use this form:

I’m seeing a new error now:

UserData.ts::migrateUserData was used. This may cause incorrect recent files sorting

Screenshot home:

Will also log issue to trimble connect.

Screenshot trimble connect:

2022-08-29 Trimble connect

Thank you, peer1979. That information is very helpful! We will continue to investigate and report back as soon as possible.

Hello, peer1979. As far as we can tell you are not experiencing quite the same problem as some of our other users. I would recommend trying again with another browser or device, or trying with an Incognito window. You might just have some stale login data.

Tried several things:

  • Deleted all cookies and browser files (same result)
  • Same browser, incognito (got a yellow message about some issue with local storage)
  • Different browser (same result)

This could be worth a try, although your errors appear to be different.

If changing DNS does not help we might be able to provide more help if you move over to the Network tab inside Chrome Developer Tools and send another screenshot.

Issue solved.

A slightly older version of my model reappeared in my account. I’ve tried to disable my pihole to see if the issue was resolved. After some trial and error my model reappeared. The strange thing is the model that appeared is slightly older (but i’m happy most of my work is there!).

So if thanks are in order; thanks to the anonymous engineer who restored a backup! Can’t see how changing dns settings triggers the appereance of an older version.

1 Like

I’m glad your cloud storage is working again. Thanks again for bringing this to our attention. If you have any further problems please don’t hesitate to reach out.

1 Like

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.