Model Info

Just downloaded Sketchup Pro 2020 (funny, “Sketchup” is redlined as not a real word in this text box).

Anyway. I used to have a hotkey for “Model Info” so that I could quickly change between decimals and fractions, or I could turn off scene animations. It looks like the 2020 update has removed the ability to put “Model info” on a hotkey.

Anyone have any ideas?

Thanks in advance! Happy Friday!

Oh I forgot the second part to my question.

My hotkey used to be command + shift + i

Now that command does something else strange and I don’t know what. Does anyone know what that command does? - I’m using a mac in case that wasn’t clear from the “command” button I’m using.

Go into Preferences>Shortcuts and filter for Model info. Then add the keyboard shortcut. If it’s assigned to something else in SketchUp, you should get a warning telling you what it is assigned to.

According to this site: https://support.apple.com/en-us/HT201236 Shift-Command-I is the shortcut to open the iCloud drive. OS hard coded shortcuts normally can’t be used.

Oh also, when I try to set shortcuts now it doesn’t work. When I hit the buttons that I want to make the shortcut, they actually perform their operation. It’s as if I’m not in the shortcuts dialog box.

But it doesn’t happen for everything. But it does happen for command + shift + i

command shift I is assigned to edit>invert selection. As Dave noted it is easily changed under preferences.

Actually I am seeing this too on Mac. It appears to be an anomaly involving trying to add the command button as a modifier for shortcuts, pressing command kicks it out of text enter mode in the window. Standby… i’m playin with it a bit.

REVISION:

I think I’m finding a bug. Edit>Invert Selection appears to be hardwired to command-shift-I. I does not appear as having a shortcut in the preferences window, although one is listed in the menu. If I try to change the shortcut for invert selection to something else ,sketchup 2020 crashes as soon as I use the new shortcut. Still investigating, @colin, can you replicate this?

REVISION:

New testing: I have successfully reset the Invert Selection shortcut to another key (letter b) and it is stable without crashing. However now both “b” and command-shift-I successfully execute a selection inversion. It’s as if that command function has two shortcuts. I am unable to add command key to any shortcuts as expected.

1 Like

Interesting developments. Thanks for looking into it! For now I’ll just pick another hotkey for Model Info =/ C’est la vie.

1 Like

Command is a special modifier that is not able to be added to all shortcut because it has specific function within the operating system. It does appear that the previous hardwired shortcut for model info which was command shift I has been changed to be the hardwired command for invert selection. There is no hardwired shortcut for model info now, but you can add one in preferences.

Shift I is available as an alternative.

1 Like

You can check if SketchUp is accepted by your spell checker.

2 Likes

Sketchup is not a valid word. SketchUp is.

I see you all got there in the end! Around about 2019.1 or .2 the invert selection feature was added. They made it use command-shift-i. I complained, but it ended up staying that way.

You should concede defeat, and find a different shortcut for Model Info.

1 Like

Hahaha I have been in the situation of fighting (and losing) the hotkey fight. Thanks for your valiant attempts Colin. Shift+I was a bit too far of a reach but Shift+W will suit me for now.