Mistakenly tried to update to latest version. (help)

I have SKU Pro 2017, which I bought in late 2017.

Shortly afterward the 2018 version rolls out, and I think awesome and try to upgrade it, thinking it was more like a Windows10 update than This-is-a-New-Program-you-have-to-purchase.

Try to run the installer to quickly discover that I have to BUY the new version, so I grumble a bit, and decide to stick with what I have.

Problem is, that because I ran the installer, I can no longer click a SKU file to open it. It now says “This file was created in a newer version of SKU”. Even though it wasn’t.

I can still open SKU 2017, and use that to open the file. But I can’t just click on the file. Been doing this for the past year, and it is a pain in the ass. Minor problem in the grand scheme of life I suppose, but still consistently annoying.

Anyone have an idea how I can remove whatever the 2018 installer did that is causing this?

Click on expand/colapse (the arrow on the right - V ), see the tutorial and choose “Repair”

Thank you for the reply.
This video solution isn’t really addressing the issue I am encountering, but I will try it anyway when I get back to my office on Monday. Maybe it will affect my issue also.
Thanks again.

Once you have installed SketchUp 2018, the files are associated to open with that version and you can also see this through the associated icon.

About rebuilding the link to another SketchUp version (2017 in your case) is this clip.

Once the link is restored, the icon and thumbnails will appear as well. These things are connected in Windows.

For this message, it looks like you opened that file and saved it in version 2018.

If you bought 2017, you automatically bought the one year maintenance and support, because this is included in the price.
That means, you had received an email with the 2018 serial and autho code.
Which means you can activate 2018 and use that version (along side the 2017 version, no need to deinstall that version)

Check your serial here:


It may be that you need to ask for the v2018 code via the renewal webform before it will be sent to you via email.

Thank you -
Downloaded 2018, installed, then ran “Repair”. Did not fix issue.
Then re-downloaded 2017, ran “Repair”, and was than able to re-assign the .skb files to open with 2017 and have it stay that way. Thank you very much for the suggestion that led to the solution!
Whew! This little glitch has been bugging me for a year; so happy to fix it.

Thanks, I got excited there for a minute to think I might have a 2018 license!
Unfortunately my memory was faulty - I actually bought 2017 in November of 2016, so when the suppot ended it was still 2017.
But thank you very much anyway.

Fixed the issue by the way, as prompted by mihai.s above:
re-installed both 2018 and 2017, ran repair on both, and was finally able to reassign which program opened the .skb files.

1 Like