Material Resizer won't install

Hello all,

I’m trying to install Material Resizer but I keep getting an error message (see attached image).

I’m on the latest version of Sketchup 2021 and on Mac.

Was really hoping to use this extension for a project I’m working on with tons of textures that are bogging down my model.

Thanks in advance for the help

I just installed it on Windows from SU2021’s internal Extension Warehouse interface.
NO problems. Installed and runs fine.

It might help if you show the context around this error message. I can’t tell if it is SketchUp, Extension Warehouse or something else stating this error message.

Try re-downloading the file from Extension Warehouse, again. I have seen that message when I had a bad download.

This is the message I get when installing the extension through extension manager. When I try installing through extension warehouse, it just freezes and crashes Sketchup all together. Neither method works.

Tried re-downloading more than once and from multiple sources. If I try installing directly from the extension warehouse I get the following error (image attached).

When things act weird, the first thing I always do is reboot the computer.

When things act weird webwise, I reset the modem and the router.

Rebooted multiple times. Tried installing the extension a couple days ago and have kept trying since including updating to the latest version of Sketchup.