Material Icon in materials doesn't change when material is changed in custom material>

Recently, I upgraded to 2020 pro from 2019 pro. I have several folders with custom colors and materials that I use for our products.
when I moved my custom materials into 2020, my materials show up in the material panels, but when I open a folder of my materials strange things happen.

the material icon selected comes in the upper left panel, but theIcon it doesn’t reflect the actual color in the material group. The material group shows the correct color, but as you click on each indiciual material in the folder, the icon in the upper left corner doesn’t change. The description changes, and when you go to edit, the color is is as it should be.

However, when I paint with the selected material, it paints the same color no matter what material I use in that folder. I can adjust the color on the edit panel, but it doesn’t change the color painted.
Example, I have made color and texture panels for metal roofing for the company we purchase the metal from. All the colors are represented in the panel with the selected folder, but its always a red color in the upper left panel, no matter what color I select.
I haven’t seen this with Sketchup standard materials, only with the materials I have created.

Any ideas? I even reloaded all my materials from my cloud, but no change. Never had an issue with these materials before, weird.
I can recreate these materials, but was hoping there was a setting I could click without have to recreate all these materials.

Incorrect SketchUp installation, maybe? Did you right click on the downloaded installer and choose Run as administrator?

I reinstalled using run as administrator, no change

I reloaded 2017, uploaded my materials into materials and the colors and textures are fine, WTH…
I used the same file I downloaded from my cloud in both versions 2017 and 2020. 2020 won’t show the proper color or texture, but 2017 will???


the User Materials paths have changed from v17 to v20…

are you copying them into the new path…


Program data/sketchup/sketchup2020/sketchup/materials
all the sketchup materials are here also, no problem with those.

did a generic search *.skm on my hard drive All my materials in here, no other materials with another address.

move them to a User Materials folder and see if they work…

the path you have now is for Application Materials…


I tried that also, I set up a setparate folder on my desktop with my materials in it. I went to 2020 materials, choose add collections, same result. Tried open folder in materials, same result. Must be something in 2020 that doesn’t like my materials.
material jpg

attached is pic of what the issue is. These are metal panels for roofing, by color and style.
I selected white, white is in the description but it shows red in the upper left and it paints red. No matter which color I choose it always paints red.

The proper and automatically enumerated path is …

%AppData%/SketchUp/SketchUp 2020/SketchUp/Materials

You’ll also find other user resource folders there for your use.

This happened to me while upgrading from 2017 to 2021.
It only applies to materials when the “Use texture image” box is ticked.
I normally use working folders for both materials and texture images, duly registered in Preferences.
When I start SketchUp, my (old) materials appear in the Materials tray in their correct colours.

  1. In the Materials Tray, I transferred (all) the custom materials using “Add to model”.
  2. Click on the “In Model” icon.
  3. Now (some of) the custom materials have texture and no colour.
    I solved the problem as follows:
  4. Still in “In Model”, I select the material and click on the edit tab.
  5. In the Texture section, click the “Browse for Material Image File” button.
  6. Open the (same) file.
  7. Click on “Undo Color Changes” next to the Color Picker.
  8. Problem solved.
  9. Delete all the old files from the working folder and replace them from the Materials tray > Details > “Save Collection As”.